Как значения в EXCEL в виде лесенки свести в одну строку?

Таких значений 28 тысяч как можно автоматизировать сей процесс?
60feb4b120e60388498094.png
  • Вопрос задан
  • 45 просмотров
Решения вопроса 2
hint000
@hint000
у админа три руки
Лень напрягать мозги, поэтому вот простенький вариант:
1) добавить новый столбец между первым и вторым.
2) допустим значение 12886 у нас в ячейке А1, тогда пишем в B1 формулу =ЕСЛИ(A1="";"";C2)
(у меня на скриншоте LibreOffiice)
3) протягиваем формулу вниз
4) скрываем столбец C (не удаляем)
5) повторяем для остальных столбцов по аналогии
60feba39d4c69600386795.png
Ответ написан
@ClearAirTurbulence
Я бы сделал так. Выделил бы все таблицу. Включил бы автофильтры, отфильтровал бы по пустым строкам в столбце А.
60fec1a51fd1b248766452.jpeg
В результате имеем видимыми только строки, где в A ничего нет:
60fec1fc106ad263654188.jpeg

В первой же пустой ячейке первого столбца ввел бы формулу конкатенации ячеек всех правых столбцов, содержащих что-либо. В русском она, ЕМНИП, называется СЦЕПИТЬ, или как-то так.
60fec238ca935491500930.jpeg

Затем скопировал бы ее, Выделил все пустые ячейки таблицы в столбце A, далее в ленте Главная, группа Редактирование, кнопка Найти и Выделить, Выделить группу ячеек, выбрать Пустые, OK (это чтобы выделить только пустые ячейки, и исключить из выделения скрытые автофильтром непустые, которые по умолчанию также выделены); далее Вставить ранее скопированную ячейку с формулой в образовавшееся выделение. Отключить автофильтры.
Получаем
60fec370c763b979599931.jpeg

Далее выделить столбец A, Скопировать, Вставить значения - чтобы из формул конкатенации преобразовать в значения. Лишние столбцы стереть.
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы