Levman5
@Levman5
Люблю програмировать

Как правильно импортировать pyautogui на python 3.9.6?

Как правильно импортировать pyautogui на python 3.9.6?

Пишу в консоли pip3 install pyautogui И получаю
Requirement already satisfied: pyautogui in c:\users\дом\appdata\local\programs\python\python39\lib\site-packages (0.9.53)
Requirement already satisfied: pymsgbox in c:\users\дом\appdata\local\programs\python\python39\lib\site-packages (from pyautogui) (1.0.7)
Requirement already satisfied: PyTweening>=1.0.1 in c:\users\дом\appdata\local\programs\python\python39\lib\site-packages (from pyautogui) (1.0.3)
Requirement already satisfied: pyscreeze>=0.1.21 in c:\users\дом\appdata\local\programs\python\python39\lib\site-packages (from pyautogui) (0.1.26)
Requirement already satisfied: pygetwindow>=0.0.5 in c:\users\дом\appdata\local\programs\python\python39\lib\site-packages (from pyautogui) (0.0.9)
Requirement already satisfied: mouseinfo in c:\users\дом\appdata\local\programs\python\python39\lib\site-packages (from pyautogui) (0.1.3)
Requirement already satisfied: pyrect in c:\users\дом\appdata\local\programs\python\python39\lib\site-packages (from pygetwindow>=0.0.5->pyautogui) (0.1.4)
Requirement already satisfied: pyperclip in c:\users\дом\appdata\local\programs\python\python39\lib\site-packages (from mouseinfo->pyautogui) (1.8.2)


Дальше в sublime text пишу
import pyautogui as pg

pg.move(50, 50)
и сохраняю. После запуска получаю ошибку
Traceback (most recent call last):
  File "C:\Users\Дом\Desktop\Py\index.py", line 1, in <module>
    import pyautogui
  File "C:\Users\Дом\AppData\Local\Programs\Python\Python39\lib\site-packages\pyautogui\__init__.py", line 221, in <module>
    locateOnWindow.__doc__ = pyscreeze.locateOnWindow.__doc__
AttributeError: module 'pyscreeze' has no attribute 'locateOnWindow'
О том что модуль pyscreeze не имеет атрибута locateOnWindow.

Но какой тут pyscreeze если у меня pyautogui?

Помогите пожалуйста
  • Вопрос задан
  • 73 просмотра
Пригласить эксперта
Ответы на вопрос 1
попробуйте написать pip uninstall pyautogui, а потом pip install pyautogui если не выйдет то нажмите WIN R и введите
c:\users\дом\appdata\local\programs\python\python39\lib\site-packages


Если не выйдет то удалите python 3.9 и скачайте python 3.7.9
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы