@lxst
Учусь программированию

Как найти значение в таблице и подставить его в другую?

При использовании впр выдаёт ошибку, каким способом можно это решить?
60bb8dc2a28ed150010713.png
  • Вопрос задан
  • 48 просмотров
Решения вопроса 1
@anoriyuriy
Здравствуйте!

В ячейке K3 стоит сумма, а в формуле ВПР первым столбцом является B, соответственно, формула ищет значение 50000 в столбце B и не находит его там, так как суммы в столбце E. Возможно, вы хотели искать сумму по имени.

Вообще можно использовать, вместо функции ВПР, функцию ИНДЕКС, тогда вы не будете привязаны к первому столбцу и вообще к порядку столбцов.
Тогда, чтобы найти сумму по имени, можно использовать следующую формулу:

=ИНДЕКС(E3:E21;ПОИСКПОЗ(K4;B3:B21;0))

Если нужно найти имя по сумме, то формула будет такая:

=ИНДЕКС(B3:B21;ПОИСКПОЗ(K3;E3:E21;0))

Если вам требуется найти что-то другое, пожалуйста, уточните. Из примера я не смог понять, что вы хотели найти формулой
Ответ написан
Пригласить эксперта
Ответы на вопрос 1
BasiC2k
@BasiC2k
Решаю проблемы за деньги. Дорого.
Скорее всего записи в К3 и колонке В отличаются (могут быть пробелы, невидимые, английские символы и тд) Попробуйте скопировать значение из таблицы и вставить в К3
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы