Контакты

Наибольший вклад в теги

Все теги (1)

Лучшие ответы пользователя

Все ответы (2)
  • Как найти значение в таблице и подставить его в другую?

    @anoriyuriy
    Здравствуйте!

    В ячейке K3 стоит сумма, а в формуле ВПР первым столбцом является B, соответственно, формула ищет значение 50000 в столбце B и не находит его там, так как суммы в столбце E. Возможно, вы хотели искать сумму по имени.

    Вообще можно использовать, вместо функции ВПР, функцию ИНДЕКС, тогда вы не будете привязаны к первому столбцу и вообще к порядку столбцов.
    Тогда, чтобы найти сумму по имени, можно использовать следующую формулу:

    =ИНДЕКС(E3:E21;ПОИСКПОЗ(K4;B3:B21;0))

    Если нужно найти имя по сумме, то формула будет такая:

    =ИНДЕКС(B3:B21;ПОИСКПОЗ(K3;E3:E21;0))

    Если вам требуется найти что-то другое, пожалуйста, уточните. Из примера я не смог понять, что вы хотели найти формулой
    Ответ написан
  • Есть ли функция в excel нахождения подстроки в строке?

    @anoriyuriy
    Желательно приложить минимально воспроизводимый пример.
    То есть: Как сейчас - Как надо

    По описанию, проблема решается просто. И формулой и условным форматированием, если действительно нужно именно выделить.

    Решение формулой

    Если в столбце A строка, в столбце B подстрока, то в C можно применить эту формулу:
    =ЕСЛИ(ЕЧИСЛО(ПОИСК(B2;A2));"содержится";"не содержится")

    60c112a72505c908594466.png

    Данная формула не содержит контроля пустой ячейки в столбце B. Его можно добавить, чтобы исключить ложные срабатывания:
    =ЕСЛИ(B2<>"";ЕСЛИ(ЕЧИСЛО(ПОИСК(B2;A2));"содержится";"не содержится");"цвет не указан!")

    60c1138f21a88953767032.png

    Решение условным форматированием

    Выбираете "Условное форматирование" - "Создать правило" - "Использовать формулу для определения форматируемых ячеек" . Ввести такую формулу:
    =ЕСЛИ(ЕЧИСЛО(ПОИСК($B2;$A2));ИСТИНА;ЛОЖЬ)
    В "Применяется к" указать нужный диапазон: =$A$2:$A$5
    Результат будет выглядеть так:
    60c117bf20a72392353201.png
    Ответ написан