Глаза боятся, а руки из жопы
Контакты
Местоположение
Россия, Санкт-Петербург и область, Санкт-Петербург

Достижения

Все достижения (3)

Наибольший вклад в теги

Все теги (73)

Лучшие ответы пользователя

Все ответы (127)
  • Как написать скрипт для mikrotik hap ac lite?

    hempy80
    @hempy80
    Внесистемный администратор
    в настройках dhcp-client во вклдке Advanced добавьте скрипт
    :local staticIP 192.168.1.182/24;
    :local newIP [/ip address get [find interface="ether1"] address];
    :if ($newIP != $staticIP) do={
       :delay 5;
       :log info "trying to change $newIP to $staticIP";
       [/ip dhcp-client release numbers=0];
    }

    замените на свои значения переменную staticIP и интерфейс, если у вас несколько dhcp-клиентов поменяете значение numbers=0 на соответствующее
    Ответ написан
  • Как смонтировать XFS на Padavan/OpenWRT?

    hempy80
    @hempy80
    Внесистемный администратор
    1) установить модуль ядра, если не установлены, для поддержки USB накопителей kmod-usb-storage, поддержки файловой системы xfs kmod-fs-xfs, пакет скриптов для монтирования block-mount
    2) подключить диск и примонтировать диск
    3) ????
    4) profit

    Информация для вдохновения
    https://openwrt.org/ru/doc/howto/usb.storage
    Ответ написан
  • Как настроить 2 сети, одна из которых виртуальная?

    hempy80
    @hempy80
    Внесистемный администратор
    Ох, эксперты понабежали. Попробую объяснить по-чайниковски. Самым простым способом решения вашей задачи это подключить виртуальные машины к сети не используя приватную подсеть за nat, а используя bridge (мост), таким образом сеть с вашими виртуалками становится частью сети 192.168.2.0, а 192.168.5.0 становится не нужна – виртуальным машинам назначаются адреса из основной сети. Более сложный случай, если есть необходимость отделить подсеть с виртуалками (для облегчения понимания лучше абстрагироваться от понятия виртуальная сеть, с точки зрения OSI это обычная подсеть с хостами) от основной сети. Как вы понимаете, для маршрутизации между подсетями должна быть некая сущность, объединяющая две L3 подсети, в вашем случае этой сущностью является ваш маршрутизатор. Короче говоря , на нём выделяется отдельный порт для подсети 192.168.5.0/24, самому порту назначается адрес из этой подсети, например 192.168.5.1, к этому порту должен быть подключен гипервизор, самому гипервизору тоже назначается адрес из этой подсети, шлюзом по умолчанию для него будет 192.168.5.1. Как и в первом случае, виртуальные машины подключается к сети через bridge (мы же помним, фактически, это просто коммутатор), адреса назначаются также из 192.168.5.0, а шлюзом для них также является 192.168.5.1 – то есть гипервизор, виртуальные машины – это всё, с точки зрения сети являются отдельными хостами. После чего все счастливы, трафик между подсетями ходит через маршрутизатор, без странных костылей в виде проброса портов и других нетрадиционных развлечений. Рассмотрим самый сложный случай, гипервизор должен находиться в одной сети (192.168.2.0), а виртуальные машины другой (192.168.5.0). В этом нам поможет технология VLAN. На маршрутизаторе также выделяется порт, но работать он должен в режиме trunk (хитрым способом объединяя внутри одного физического сегмента два или более L2-домена), в общем-то, это всё тот же второй случай, только с настройкой vlan-интерфейсов как на гипервизоре, так и на маршрутизаторе. Как вы понимаете, для второго и третьего случая не подойдет обычный домашний роутер (если, конечно, он не доведен до ума альтернативной прошивкой openwrt).
    Как-то так. можно было бы и детальнее подсказать, если укажите модель вашего маршрутизатора и какой гипервизор вы используете.
    Ответ написан
  • Как правильно настроить Маскарадинг в Mikrotik?

    hempy80
    @hempy80
    Внесистемный администратор
    Нужно использовать не маскарад, а правило snat,
    Задачу можно разделить на три этапа
    Этап 1 разделить на пять групп устанавливаемые соединения по критерию source адрес (У вас указано только четыре внешних адреса, поэтому пример будет для четырёх, также сеть 172.19.123.0/24 не может быть приватной, но хозяин-барин и в примере оставлено как указано у вас)
    Этап 2 Промаркировать соединение из каждой группы соответствующей меткой
    Этап 3 пропустить трафик групп через соответствующие им правила source nat согласно присвоенной метки

    /ip firewall mangle
    add action=mark-connection chain=prerouting new-connection-mark=1st_conn \
    per-connection-classifier=src-address:4/0 src-address=172.19.123.0/24
    add action=mark-connection chain=prerouting new-connection-mark=2st_conn \
    per-connection-classifier=src-address:4/1 src-address=172.19.123.0/24
    add action=mark-connection chain=prerouting new-connection-mark=3st_conn \
    per-connection-classifier=src-address:4/2 src-address=172.19.123.0/24
    add action=mark-connection chain=prerouting new-connection-mark=4st_conn \
    per-connection-classifier=src-address:4/3 src-address=172.19.123.0/24

    /ip firewall nat
    add action=src-nat chain=srcnat connection-mark=1st_conn out-interface=ether1 \
    to-addresses=192.168.8.2
    add action=src-nat chain=srcnat connection-mark=2st_conn out-interface=ether1 \
    to-addresses=192.168.8.3
    add action=src-nat chain=srcnat connection-mark=3st_conn out-interface=ether1 \
    to-addresses=192.168.8.4
    add action=src-nat chain=srcnat connection-mark=5st_conn out-interface=ether1 \
    to-addresses=192.168.8.5

    других правил маскарада выше этих быть не должно
    Ответ написан

Лучшие вопросы пользователя

Все вопросы (9)