Только учусь писать код )

Достижения

Все достижения (18)

Наибольший вклад в теги

Все теги (86)

Лучшие ответы пользователя

Все ответы (36)
  • Как запустить Angularjs проект на сервер nodejs?

    @Scorpiored88 Автор вопроса
    Я недавно начал изучать angular.Сделал несколько проектов для себя на angular PhoneGap с сервером api на node express.
    Дело в том что angular PhoneGap приложения запускает сам телефон(или сервер на нем,точно не знаю),тоесть я вручную не скармливаю angular какому то серверу... В оф. Документации,а именно в туториале,ангулара,кратко сказано про какой то простой сервер на ноде и все...
    Я же просто хочу понять принцип работы...кто кому что скармливает...
    Вот допустим есть у меня несколько html страниц,для того чтобы переходя по заданному адресу открывать их,я запущу сервер на ноде (express) которий собственно и будет рендерить ети страницы и отвечать на get и post запросы и тд... тут все понятно.
    А как в случае с ангуларом? Правильно ли будет если я,етому же серверу по запросу на определённый адрес буду отдавать response.render(index)... index.html ангулара ,к которому собственно все и привязовается в етом фреймворке? Будете ли ето работать вообще?
    Или же тут Инной принцип,запускаем простейший http сервер с примера в туториале про ангулар, на своём сервера и все,етого достаточно...,ето релиз...,и таким образом мой angular проект выходит в свет?
    Разжуйте пожалуйста,а то на angular вроде как пишу,и expressОМ пользуюсь и модули разные подключаю,но вот куда и как прикрутить мой сайт на ангулар я не знаю (за исключениям PhoneGap).... :(
    П.С. Извините за ошибки,сейчас пишу с телефона
    Ответ написан
  • Как подключится к VPN L2TP серверу (Mikrotik) за NAT если все порты открыты?

    @Scorpiored88 Автор вопроса
    Это личися правкой реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PolicyAgent , а именно добавлениям туда параметра AssumeUDPEncapsulationContextOnSendRule со значениям 1 или 2.
    И не забываем после этого перегрузить ПК
    Ответ написан
  • Как впустить конкретную машину через конкретный шлюз в Mikrotik?

    @Scorpiored88 Автор вопроса
    Интересно. Но у меня как бы и так работает :
    /ip firewall mangle
    add action=mark-routing chain=prerouting new-routing-mark=tv passthrough=no src-address=192.168.88.100
    и
    /ip route
    add comment=reserve distance=2 gateway=2.2.2.2 routing-mark=tv
    add comment=main distance=1 gateway=1.1.1.1

    Но вот в случии если основной шлюз упадет, и микортик переключится на резерв, то все ли устройсва тоже будут ходить через шлюз reserve или только 192.168.88.100 ? а остальным будет не дано ?
    П.С. Переход на резерв осуществ через скрипты
    Ответ написан

Лучшие вопросы пользователя

Все вопросы (233)