@Espio
Стажёр в 1С

Как обратится к стандартным командам формы?

Создал на форме свою команду.
&НаСервере
Процедура ПерерасчетНаСервере()
	
	Для каждого Стр из Отчет.ТЗ_Результат Цикл
		СсылкаНаДокумент = Стр.ОбъектПерерасчета;
		Если НЕ СсылкаНаДокумент = Неопределено Тогда
			ДокументОбъект = СсылкаНаДокумент.ПолучитьОбъект();
			ДокументОбъект.Записать(РежимЗаписиДокумента.Проведение);
		КонецЕсли;
	КонецЦикла;

КонецПроцедуры

&НаКлиенте
Процедура Перерасчет(Команда)
	
	ПерерасчетНаСервере();
	
КонецПроцедуры


Хочу сделать так, чтобы после того, как отработал этот алгоритм, сработала стандартная команда формы "Сформировать". Не смог нагуглить как к ней обратится, прошу о помощи здесь.
  • Вопрос задан
  • 49 просмотров
Пригласить эксперта
Ответы на вопрос 1
fosihas
@fosihas
Автоматизации учета на 1С.
https://helpf.pro/faq83/view/1883.html
https://forum.infostart.ru/forum9/topic76236/
в коде
&НаКлиенте
Процедура Перерасчет(Команда)

напиши Сформировать, если коммана должна быть Процедура, пропиши ее.
Не знаешь что выполняется, включи отладчик и нажми Сфомировать. Поймешь что выполняется.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы