@Land-Maze

Почему при заходе в Debian сбрасывает настройки eth0?

Установил я себе значит новый дистрибутив на "основе" Debian. И я при установке сразу заметил что-то странное, при автоматической настройки сети он сказал что DHCP сервер либо медленный либо не использую его. DHCP используется как раз, и он дал ему 192.168.100.3, я попробовал зарезервировать этот ip и вручную прописать настройки. Всё равно чуда не случилось, пробовал прописать в interfaces
auto eth0
iface eth0 inet static
address 192.168.100.3
gateway 192.168.100.1
netmask 255.255.255.0

Тоже ничего

Только вот кое-что скажу. При том когда я захожу в Linux с поломанными настройками он сбрасывает настройки и на Windows. Вот что авто исправление шиндовс показало
5fe882728e101810407771.png

Ещё хочу сказать что при чистом Debian такого не было

ps.
IP у меня серый
DNS провайдера
KDE оболочка
  • Вопрос задан
  • 63 просмотра
Решения вопроса 1
@Land-Maze Автор вопроса
Я не знаю, удалять ли вопрос или оставить тем кто тоже ищет решение.
Я не знаю толком в чём проблема но видимо всё решается так :
sudo dhclient && systemctl reboot
И должно показать сеть после перезагрузки.
Если же у вас не появился проверьте командой ещё раз sudo dhclient
Если отображает RTLink : file exist то проблема видимо в другом и не как у меня
И в команде ip a должно появиться новая строчка в кат. eth0

Зашёл я значит назад на Linux чтобы сделать скриншоты ip a и ifconfig. Захожу в браузер чтобы запостить на хабре, и тут я даже не заметил что у меня интернет появился. ЧУДО!
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы