nastya97core
@nastya97core
Начинающий программист

Как на slax (debian) установить Яндекс Браузер?

Здравствуйте. Мне нужна была флешка со своей системой. Начала изучать вопрос и пришла к выводу, что самая низкотребовательная и быстрая система - это SLAX (https://www.slax.org/ ). Я бы хотела использовать Яндекс Браузер, однако у меня не получается его туда установить. Вот что я делаю:
Много строк

root@slax:~# dpkg -i /home/guest/Downloads/ya.deb
Selecting previously unselected package yandex-browser-beta.
(Reading database ... 37437 files and directories currently installed.)
Preparing to unpack /home/guest/Downloads/ya.deb ...
Unpacking yandex-browser-beta (20.9.3.189-1) ...
dpkg: dependency problems prevent configuration of yandex-browser-beta:
 yandex-browser-beta depends on fonts-liberation; however:
  Package fonts-liberation is not installed.
 yandex-browser-beta depends on jq; however:
  Package jq is not installed.
 yandex-browser-beta depends on libappindicator3-1; however:
  Package libappindicator3-1 is not installed.
 yandex-browser-beta depends on libatk-bridge2.0-0 (>= 2.5.3); however:
  Package libatk-bridge2.0-0 is not installed.
 yandex-browser-beta depends on libgtk-3-0 (>= 3.9.10); however:
  Package libgtk-3-0 is not installed.

dpkg: error processing package yandex-browser-beta (--install):
 dependency problems - leaving unconfigured
Processing triggers for menu (2.1.47+b1) ...
Processing triggers for man-db (2.7.6.1-2) ...
Processing triggers for mime-support (3.60) ...
Errors were encountered while processing:
 yandex-browser-beta
root@slax:~# apt install -f 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  adwaita-icon-theme dconf-gsettings-backend dconf-service fonts-liberation glib-networking
  glib-networking-common glib-networking-services gsettings-desktop-schemas jq
  libappindicator3-1 libatk-bridge2.0-0 libcairo-gobject2 libcolord2 libdbusmenu-glib4
  libdbusmenu-gtk3-4 libdconf1 libgtk-3-0 libgtk-3-common libindicator3-7 libjq1
  libjson-glib-1.0-0 libjson-glib-1.0-common liblcms2-2 libonig4 libproxy1v5 librest-0.7-0
  libsoup-gnome2.4-1 libsoup2.4-1 libwayland-cursor0 libwayland-egl1-mesa
Suggested packages:
  colord gvfs liblcms2-utils
Recommended packages:
  libgtk-3-bin
The following NEW packages will be installed:
  adwaita-icon-theme dconf-gsettings-backend dconf-service fonts-liberation glib-networking
  glib-networking-common glib-networking-services gsettings-desktop-schemas jq
  libappindicator3-1 libatk-bridge2.0-0 libcairo-gobject2 libcolord2 libdbusmenu-glib4
  libdbusmenu-gtk3-4 libdconf1 libgtk-3-0 libgtk-3-common libindicator3-7 libjq1
  libjson-glib-1.0-0 libjson-glib-1.0-common liblcms2-2 libonig4 libproxy1v5 librest-0.7-0
  libsoup-gnome2.4-1 libsoup2.4-1 libwayland-cursor0 libwayland-egl1-mesa
0 upgraded, 30 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 21.2 MB of archives.
After this operation, 75.7 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://deb.debian.org/debian stretch/main amd64 fonts-liberation all 1:1.07.4-2 [827 kB]
Get:2 http://security.debian.org/debian-security stretch/updates/main amd64 libonig4 amd64 6.1.3-2+deb9u1 [147 kB]
Get:3 http://security.debian.org/debian-security stretch/updates/main amd64 libproxy1v5 amd64 0.4.14-2+deb9u2 [55.8 kB]
Get:4 http://deb.debian.org/debian stretch/main amd64 libjq1 amd64 1.5+dfsg-1.3 [123 kB]
Get:5 http://deb.debian.org/debian stretch/main amd64 jq amd64 1.5+dfsg-1.3 [58.6 kB]
Get:6 http://deb.debian.org/debian stretch/main amd64 libcairo-gobject2 amd64 1.14.8-1 [336 kB]
Get:7 http://deb.debian.org/debian stretch/main amd64 libdbusmenu-glib4 amd64 12.10.2-2 [104 kB]
Get:8 http://deb.debian.org/debian stretch/main amd64 libdbusmenu-gtk3-4 amd64 12.10.2-2 [91.0 kB]
Get:9 http://deb.debian.org/debian stretch/main amd64 libdconf1 amd64 0.26.0-2+b1 [37.6 kB]
Get:10 http://deb.debian.org/debian stretch/main amd64 dconf-service amd64 0.26.0-2+b1 [34.7 kB]
Get:11 http://deb.debian.org/debian stretch/main amd64 dconf-gsettings-backend amd64 0.26.0-2+b1 [26.4 kB]
Get:12 http://deb.debian.org/debian stretch/main amd64 libgtk-3-common all 3.22.11-1 [3,416 kB]
Get:13 http://deb.debian.org/debian stretch/main amd64 libatk-bridge2.0-0 amd64 2.22.0-2 [56.3 kB]
Get:14 http://deb.debian.org/debian stretch/main amd64 liblcms2-2 amd64 2.8-4+deb9u1 [143 kB]   
Get:15 http://deb.debian.org/debian stretch/main amd64 libcolord2 amd64 1.3.3-2 [252 kB]        
Get:16 http://deb.debian.org/debian stretch/main amd64 libjson-glib-1.0-common all 1.2.6-1 [166 kB]
Get:17 http://deb.debian.org/debian stretch/main amd64 libjson-glib-1.0-0 amd64 1.2.6-1 [178 kB]
Get:18 http://deb.debian.org/debian stretch/main amd64 glib-networking-common all 2.50.0-1+deb9u1 [49.2 kB]
Get:19 http://deb.debian.org/debian stretch/main amd64 glib-networking-services amd64 2.50.0-1+deb9u1 [12.2 kB]
Get:20 http://deb.debian.org/debian stretch/main amd64 gsettings-desktop-schemas all 3.22.0-1 [473 kB]
Get:21 http://deb.debian.org/debian stretch/main amd64 glib-networking amd64 2.50.0-1+deb9u1 [57.0 kB]
Get:22 http://deb.debian.org/debian stretch/main amd64 libsoup2.4-1 amd64 2.56.0-2+deb9u2 [296 kB]
Get:23 http://deb.debian.org/debian stretch/main amd64 libsoup-gnome2.4-1 amd64 2.56.0-2+deb9u2 [16.4 kB]
Get:24 http://deb.debian.org/debian stretch/main amd64 librest-0.7-0 amd64 0.8.0-2 [33.0 kB]    
Get:25 http://deb.debian.org/debian stretch/main amd64 libwayland-cursor0 amd64 1.12.0-1+deb9u1 [13.5 kB]
Get:26 http://deb.debian.org/debian stretch/main amd64 libwayland-egl1-mesa amd64 13.0.6-1+b2 [43.0 kB]
Get:27 http://deb.debian.org/debian stretch/main amd64 adwaita-icon-theme all 3.22.0-1+deb9u1 [11.5 MB]
Get:28 http://deb.debian.org/debian stretch/main amd64 libgtk-3-0 amd64 3.22.11-1 [2,529 kB]    
Get:29 http://deb.debian.org/debian stretch/main amd64 libindicator3-7 amd64 0.5.0-3+b1 [52.8 kB]
Get:30 http://deb.debian.org/debian stretch/main amd64 libappindicator3-1 amd64 0.4.92-4 [52.6 kB]
Fetched 21.2 MB in 30s (695 kB/s)                                                               
Selecting previously unselected package fonts-liberation.
(Reading database ... 37690 files and directories currently installed.)
Preparing to unpack .../00-fonts-liberation_1%3a1.07.4-2_all.deb ...
Unpacking fonts-liberation (1:1.07.4-2) ...
Selecting previously unselected package libonig4:amd64.
Preparing to unpack .../01-libonig4_6.1.3-2+deb9u1_amd64.deb ...
Unpacking libonig4:amd64 (6.1.3-2+deb9u1) ...
Selecting previously unselected package libjq1:amd64.
Preparing to unpack .../02-libjq1_1.5+dfsg-1.3_amd64.deb ...
Unpacking libjq1:amd64 (1.5+dfsg-1.3) ...
Selecting previously unselected package jq.
Preparing to unpack .../03-jq_1.5+dfsg-1.3_amd64.deb ...
Unpacking jq (1.5+dfsg-1.3) ...
Selecting previously unselected package libcairo-gobject2:amd64.

*** много таких же однотипных Selecting Preparing Unpacking ***
*** удалила, потому что нельзя более 10к символов ***

Setting up yandex-browser-beta (20.9.3.189-1) ...
--2020-12-03 15:26:08--  https://launchpadlibrarian.net/498540836/chromium-codecs-ffmpeg-extra_85.0.4183.121-0ubuntu0.16.04.1_amd64.deb
Resolving launchpadlibrarian.net (launchpadlibrarian.net)... 91.189.89.228, 91.189.89.229, 2001:67c:1560:8003::8008, ...
Connecting to launchpadlibrarian.net (launchpadlibrarian.net)|91.189.89.228|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1116834 (1.1M) [application/x-debian-package]
Saving to: ‘/tmp/tmp.1mKUhSHWZm/tmp.1rzHFuaYuz’

/tmp/tmp.1mKUhSHWZm/tmp. 100%[===============================>]   1.06M   447KB/s    in 2.4s 
2020-12-03 15:26:11 (447 KB/s) - ‘/tmp/tmp.1mKUhSHWZm/tmp.1rzHFuaYuz’ saved [1116834/1116834]

/opt/yandex/browser-beta/update-ffmpeg: line 30: ar: command not found
FFMPEG codecs installation failed
update-alternatives: using /usr/bin/yandex-browser-beta to provide /usr/bin/yandex-browser (yandex-browser) in auto mode
Processing triggers for libc-bin (2.24-11+deb9u4) ...
Processing triggers for menu (2.1.47+b1) ...
root@slax:~# dpkg -i /home/guest/Downloads/ya.deb
(Reading database ... 43878 files and directories currently installed.)
Preparing to unpack /home/guest/Downloads/ya.deb ...
Unpacking yandex-browser-beta (20.9.3.189-1) over (20.9.3.189-1) ...
Setting up yandex-browser-beta (20.9.3.189-1) ...
--2020-12-03 15:29:00--  https://launchpadlibrarian.net/498540836/chromium-codecs-ffmpeg-extra_85.0.4183.121-0ubuntu0.16.04.1_amd64.deb
Resolving launchpadlibrarian.net (launchpadlibrarian.net)... 91.189.89.229, 91.189.89.228, 2001:67c:1560:8003::8007, ...
Connecting to launchpadlibrarian.net (launchpadlibrarian.net)|91.189.89.229|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1116834 (1.1M) [application/x-debian-package]
Saving to: ‘/tmp/tmp.vFetUQZpaI/tmp.tmxhRIaEiC’

/tmp/tmp.vFetUQZpaI/tmp. 100%[===============================>]   1.06M   240KB/s    in 4.6s    

2020-12-03 15:29:05 (239 KB/s) - ‘/tmp/tmp.vFetUQZpaI/tmp.tmxhRIaEiC’ saved [1116834/1116834]

/opt/yandex/browser-beta/update-ffmpeg: line 30: ar: command not found
FFMPEG codecs installation failed
Processing triggers for menu (2.1.47+b1) ...
Processing triggers for man-db (2.7.6.1-2) ...
Processing triggers for mime-support (3.60) ...


Перед этим я сделала apt upgrade.

После этого в меню появляется ярлык яндекса с названием New incognito, который не реагирует на нажатие.

Скажите, что нужно сделать, чтобы установить яндекс браузер? Я вообще не дружу с linux, а нормальной live usb windows я не нашла, которая включалась бы также быстро
  • Вопрос задан
  • 117 просмотров
Пригласить эксперта
Ответы на вопрос 1
vasilyevmn
@vasilyevmn
DevOps
Ответ на ваш вопрос тут:
Как установить кодеки в Яндекс Браузер в Manjaro Linux 19?
Читайте внимательно.

PS лучше Chromium.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы