Да, очередная ошибка. Composer?

compser.json:
{
    "name": "laravel/laravel",
    "type": "project",
    "description": "The Laravel Framework.",
    "keywords": [
        "framework",
        "laravel"
    ],
    "license": "MIT",
    "require": {
        "php": "^7.3",
        "fideloper/proxy": "^4.2",
        "fruitcake/laravel-cors": "^2.0",
        "guzzlehttp/guzzle": "^7.0.1",
        "laravel/framework": "^8.0",
        "laravel/tinker": "^2.0"
    },
    "require-dev": {
        "facade/ignition": "^2.3.6",
        "fzaninotto/faker": "^1.9.1",
        "mockery/mockery": "^1.3.1",
        "nunomaduro/collision": "^5.0",
        "phpunit/phpunit": "^9.3"
    },
    "config": {
        "optimize-autoloader": true,
        "preferred-install": "dist",
        "sort-packages": true
    },
    "extra": {
        "laravel": {
            "dont-discover": []
        }
    },
    "autoload": {
        "psr-4": {
            "App\\": "app/",
            "Database\\Factories\\": "database/factories/",
            "Database\\Seeders\\": "database/seeders/"
        }
    },
    "autoload-dev": {
        "psr-4": {
            "Tests\\": "tests/"
        }
    },
    "minimum-stability": "dev",
    "prefer-stable": true,
    "scripts": {
        "post-autoload-dump": [
            "Illuminate\\Foundation\\ComposerScripts::postAutoloadDump",
            "@php artisan package:discover --ansi"
        ],
        "post-root-package-install": [
            "@php -r \"file_exists('.env') || copy('.env.example', '.env');\""
        ],
        "post-create-project-cmd": [
            "@php artisan key:generate --ansi"
        ]
    }
}


ОШИБКА:
[ts@MyNameIsTS auth]$ composer require laravel/fortify
PHP Warning:  Module 'zip' already loaded in Unknown on line 0
Using version ^1.6 for laravel/fortify
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - laravel/fortify 1.x-dev requires bacon/bacon-qr-code ^2.0 -> satisfiable by bacon/bacon-qr-code[2.0.0, 2.0.1, 2.0.2].
    - laravel/fortify v1.6.0 requires bacon/bacon-qr-code ^2.0 -> satisfiable by bacon/bacon-qr-code[2.0.0, 2.0.1, 2.0.2].
    - laravel/fortify v1.6.1 requires bacon/bacon-qr-code ^2.0 -> satisfiable by bacon/bacon-qr-code[2.0.0, 2.0.1, 2.0.2].
    - bacon/bacon-qr-code 2.0.2 requires ext-iconv * -> the requested PHP extension iconv is missing from your system.
    - bacon/bacon-qr-code 2.0.1 requires ext-iconv * -> the requested PHP extension iconv is missing from your system.
    - bacon/bacon-qr-code 2.0.0 requires ext-iconv * -> the requested PHP extension iconv is missing from your system.
    - Installation request for laravel/fortify ^1.6 -> satisfiable by laravel/fortify[1.x-dev, v1.6.0, v1.6.1].

  To enable extensions, verify that they are enabled in your .ini files:
    - /etc/php/php.ini
    - /etc/php/conf.d/apcu.ini
    - /etc/php/conf.d/xdebug.ini
    - /etc/php/conf.d/zoneminder.ini
  You can also run `php --ini` inside terminal to see which files are used by PHP in CLI mode.

Installation failed, reverting ./composer.json to its original content.

[ts@MyNameIsTS auth]$ php --ini
PHP Warning:  Module 'zip' already loaded in Unknown on line 0
Configuration File (php.ini) Path: /etc/php
Loaded Configuration File:         /etc/php/php.ini
Scan for additional .ini files in: /etc/php/conf.d
Additional .ini files parsed:      /etc/php/conf.d/apcu.ini,
/etc/php/conf.d/xdebug.ini,
/etc/php/conf.d/zoneminder.ini


Прошу о помощи, Спасибо!
  • Вопрос задан
  • 42 просмотра
Пригласить эксперта
Ответы на вопрос 1
@Vitsliputsli
А что конкретно непонятно? Вроде бы достаточно четко написано:
the requested PHP extension iconv is missing from your system.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы