@severnik

Как настроить Mikrotik, чтобы при нажатии кнопки Mode восстанавливалась последняя конфигурация из backup?

Взял Mikrotik HAP ac2 на замену старого роутера другого производителя. Пробую крутить-настраивать разные штуки на нём и в процессе иногда набиваю шишки, окирпичивая его. Знаю, что есть Safe mode в WinBox, но тоже иногда забываю его включить.

Приходится сбрасывать кнопкой Reset. Она там очень тугая и неудобно расположена. Не знаю, может это мне такой экземпляр попался и в других всё хорошо. Кто так запроектировал, что Reset и светодиод его индикации в нескольких миллиметрах друг от друга, тоже непонятно. Получается, я закрываю пальцем светодиод, который должен замигать для индикации сброса. Если бы это была утопленная кнопка, как делали раньше, которую скрепкой надо нажимать, вопросов не было бы.

И потом всё равно же накатываю backup после сброса. Было бы удобно настроить под это кнопку Mode, которая рядом с USB портом, с параметрами:
  • Нажатие - восстанавливать последнюю конфигурацию из backup
  • Удержание 5сек. - сброс настроек к заводским

Подскажите, пожалуйста, как это можно реализовать? Хотя бы один из режимов.
  • Вопрос задан
  • 163 просмотра
Решения вопроса 1
/system script add name=load-backup source={/system backup load name=backup_name}
/system routerboard mode-button set on-event=load-backup enabled=yes


сброс настроек к заводским заскриптовать сложнее из-за того, что вызов команды отображает запрос на подтверждение. https://forum.mikrotik.com/viewtopic.php?t=121491
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы