@karpo518

Почему composer update выдает ошибку?

composer.json
{
    "require": {
        "phpmailer/phpmailer": "^6.0",
        "bogdaan/viber-bot-php": "^0.0.12",
        "brickpop/php-rest-curl": "master"
    },
    "repositories": [
    	{
      		"type": "vcs",
			"url": "git@github.com:brickpop/php-rest-curl.git"
    	}
  	]
}

composer install -vvv
composer install -vvv
Reading ./composer.json
Loading config file ./composer.json
Checked CA file /etc/ssl/certs/ca-certificates.crt: valid
Executing command (/path/to/folder): git branch --no-color --no-abbrev -v
Executing command (/path/to/folder): git describe --exact-match --tags
Executing command (/path/to/folder): git log --pretty="%H" -n1 HEAD
Executing command (/path/to/folder): hg branch
Executing command (/path/to/folder): fossil branch list
Executing command (/path/to/folder): fossil tag list
Executing command (/path/to/folder): svn info --xml
Reading /home/k/karpo518/.composer/composer.json
Loading config file /home/k/karpo518/.composer/composer.json
Reading /path/to/folder/vendor/composer/installed.json
Reading /home/k/kuser1/.composer/vendor/composer/installed.json
Running 1.8.6 (2019-06-11 15:03:05) with PHP 5.6.40 on Linux / 4.9.207-1-beget-acl
Reading ./composer.lock
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Reading ./composer.lock
Warning: The lock file is not up to date with the latest changes in composer.json. You may be getting outdated dependencies. Run update to update them.
Resolving dependencies through SAT
Looking at all rules.

Dependency resolution completed in 0.001 seconds
Analyzed 104 packages to resolve dependencies
Analyzed 132 rules to resolve dependencies
Nothing to install or update
Generating autoload files

composer update
composer update
Loading composer repositories with package information
                                                                           
                                                                                                          
  [Composer\Repository\InvalidRepositoryException]                                                        
  No valid composer.json was found in any branch or tag of git@github.com:brickpop/php-rest-curl.git, co  
  uld not load a package from it.                                                                         
                                                                                                          

update [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--lock] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--no-suggest] [--with-dependencies] [--with-all-dependencies] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [-i|--interactive] [--root-reqs] [--] [<packages>]...
  • Вопрос задан
  • 73 просмотра
Решения вопроса 1
BoShurik
@BoShurik
Symfony developer
{
    "require": {
        "phpmailer/phpmailer": "^6.0",
        "bogdaan/viber-bot-php": "^0.0.12",
        "brickpop/php-rest-curl": "^1.0"
    },
    "repositories": {
        "php-rest-curl": {
            "type": "package",
            "package": {
                "name": "brickpop/php-rest-curl",
                "version": "1.0.0",
                "source": {
                    "url": "git@github.com:brickpop/php-rest-curl.git",
                    "type": "git",
                    "reference": "master"
                },
                "autoload": {
                    "files": ["rest.inc.php"]
                }
            }
        }
    }
}
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы