Login8
@Login8
Программист, критик, наватор

Почему не работает https сертификат?

Здраствуйте уважаемые знатоки.
Настраивал Lets Encrypt сертификаты при помощи certbot.
Когда я первый раз настраивал сертификаты https я сначало это сделал для site1.com потом для остальных site2.com , site3.com и site4.com . Все на одном сервере. Таким образом для каждого сайта свой сертификат и все работало. Но, спустя какое то время я заметил что сайты которые настраивались после site1.com неработают и браузер говорит что типа проблемы с сертификатом. Я пробил сертификаты этих сайтов и выяснилось что они принадлежат почему то site1.com. Долго не мог понять что произошло. Что за баг, начал гуглить ничего не нагуглил но нашол способ как все сайты на одном сервере обьеденить в один сертификат, сделал, все супер, но это не очень круто. Сегодня я решил еще раз более внимательно настроить для каждого сайта СВОЙ сертифмкат https. Сделал. Все работало какое то время и опять!!! Опять через несколько минут все слетело. Короче вот что я думаю: этот certbot сволочь такая, как то проверяет сервер и если находит там несколько сертификатов для разных сайтов, то их удаляет или портит, я незнаю что он делает, но в итоге остается работоспособным только самый первый сайт site1.com . Ну никак неполучается сделать для каждого свой, хоть ты застрелись.
Может кто то сталкивался с этой проблемой, подскажите что происходит?
  • Вопрос задан
  • 58 просмотров
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы