rock3t
@rock3t
System Engineer

Как решить ошибку в плейбук-файле?

5eefa47191e4b576846931.png

5eefa47859e90618769566.png

Буквально на днях начал изучать Ансибл, написал простенький плейбук для установки апача на все свои хосты (2 истанста поднятых в амазоне) , получаю следующуюю ошибку, чувствую, что что-то простое, но сам пока ошибки не заметил

Плейбук: - name: Install default Apache Web Server
hosts: all
become: yes

tasks:
- name: Install Apache WebServer
apt: name=httpd state=latest

- name: Start Apache and Enable it on the every boot
service: name=httpd state=started enabled=yes

Ошибка: fatal: [linux1]: FAILED! => {"cache_update_time": 1586367636, "cache_updated": false, "changed": false, "msg": "'/usr/bin/apt-get -y -o \"Dpkg::Options::=--force-confdef\" -o \"Dpkg::Options::=--force-confold\" install 'httpd'' failed: E: Package 'httpd' has no installation candidate\n", "rc": 100, "stderr": "E: Package 'httpd' has no installation candidate\n", "stderr_lines": ["E: Package 'httpd' has no installation candidate"], "stdout": "Reading package lists...\nBuilding dependency tree...\nReading state information...\nPackage httpd is a virtual package provided by:\n nginx-core 1.14.0-0ubuntu1.7\n apache2 2.4.29-1ubuntu4.13\n\n", "stdout_lines": ["Reading package lists...", "Building dependency tree...", "Reading state information...", "Package httpd is a virtual package provided by:", " nginx-core 1.14.0-0ubuntu1.7", " apache2 2.4.29-1ubuntu4.13", ""]}
fatal: [linux2]: FAILED! => {"cache_update_time": 1586367636, "cache_updated": false, "changed": false, "msg": "'/usr/bin/apt-get -y -o \"Dpkg::Options::=--force-confdef\" -o \"Dpkg::Options::=--force-confold\" install 'httpd'' failed: E: Package 'httpd' has no installation candidate\n", "rc": 100, "stderr": "E: Package 'httpd' has no installation candidate\n", "stderr_lines": ["E: Package 'httpd' has no installation candidate"], "stdout": "Reading package lists...\nBuilding dependency tree...\nReading state information...\nPackage httpd is a virtual package provided by:\n nginx-core 1.14.0-0ubuntu1.7\n apache2 2.4.29-1ubuntu4.13\n\n", "stdout_lines": ["Reading package lists...", "Building dependency tree...", "Reading state information...", "Package httpd is a virtual package provided by:", " nginx-core 1.14.0-0ubuntu1.7", " apache2 2.4.29-1ubuntu4.13", ""]}
  • Вопрос задан
  • 35 просмотров
Решения вопроса 1
@q2digger
сисадмин
Ошибки в виде текста сделайте. Рассматривать размытые скриншоты - удовольствие не очень.
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы