@Asteroid363

Как отослать логи с Mikrotika о времени подлключения vpn клиентов?

Как отослать логи с Mikrotika о времени подлключения vpn клиентов на другой syslog сервер ?
Суть вопроса в самом скрипте логирования?
  • Вопрос задан
  • 2031 просмотр
Пригласить эксперта
Ответы на вопрос 4
@kprohorow
В system -> logging добавить action с типом remote и указать адрес сервера.
Затем в правилах указать нужные топики (l2tp, ppp, info - например) с созданным ранее действием.
Хотя лучше логировать всё и сразу. Никогда не знаешь что понадобится в будущем )
Ответ написан
Комментировать
martin74ua
@martin74ua
Linux administrator
использовать для авторизации радиус сервер. В нем сразу увидите и время коннекта, и время дисконнекта....
Ответ написан
Комментировать
@Mister5114
Поставить на мониторинг в забиксе
Ответ написан
Комментировать
@PapaTramp
В профиле L2TP прописать скрипт на событие OnUp
:local email "your@email.com"
/tool e-mail send to=$email subject="User $user connected to VPN" body="User $user connected to $[/ppp active get [/ppp active find where name=$user caller-id=$"caller-id" address=$"remote-address"] service] at $[/system clock get time].\r\nIP-address of this user - $"caller-id".\r\nUser's info - apps.db.ripe.net/search/query.html?searchtext=$"caller-id""
На событие OnDown
:local email "your@email.com"
/tool e-mail send to=$email subject="User $user disconnected from VPN" body="User $user disconnected at $[/system clock get time]."
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы