Почему не запускается Debian 10 на другом пк с UEFI?

Ради интереса, взял USB Диск на 500GB, что бы таскать с собой рабочее место на Debian 10, со всем окружением.
Поставил с LiveCD на диск, разметив Encrypted LVM, да бы если его потеряю, никто не смог бы им воспользоваться.
Установка на железе с полным UEFI , без каких либо CSM.
Разметил по дефолту all in one /dev/sda
Партишены:
/dev/sda1 - fat32 /boot/efi - флаги boot и esp
/dev/sda2 - ext2 /boot
/dev/sda3 - Шифрованное добро

Всё прекрасно, по USB3.0 работает, грузится.
Окей думаю я, доделаю дома, а вот фиг, UEFI не грузится, в обще как будто диск для него пустой. Ладно, черт с ним, начал то же самое делать на домашнем ПК, стер диск под ноль, поставил, работает ОС, USB2.0 только, ну это не принципиально.
Ну чтож, принес обратно на рабочий комп, а там такая же ерунда UEFI так же ничего не видит, типа диск пустой, никаких "boot manager" или подобного.

Что я упустил? На MBR я помню, сервачок подгорел, ничего, пошел диск в другой сервер воткнул и работает себе, а с EFI так не прокатит?
  • Вопрос задан
  • 965 просмотров
Решения вопроса 1
Kenny00
@Kenny00 Автор вопроса
Решение быстрее нашлось на другом ресурсе: Решение

Force_grub-efi_installation_to_the_removable_media_path
GrubEFIReinstall#Problem1:_Weak_EFI_implementation...

По сути - форсированая переустановка загрузчика через Rescue Mode с LiveCD .
Ответ написан
Комментировать
Пригласить эксперта
Ответы на вопрос 1
Oxyd
@Oxyd
Linux enthusiast
Подозреваю что у вас разделы, в /etc/fstab прописаны как /dev/sd а не UUID= Покажите, что у вас в /etc/fstab:
cat /etc/fstab
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы