@belyaevcyrill

Как объединить две одинаковые подсети через IPIP на Микротике?

Есть два удаленных друг от друга офиса. У обоих подсеть 10.10.3.0/24.
У обоих Микротиков WAN'овский IP белый.

IPIP в бридж не засунешь, как EoIP. Пробовал на Микротике 1 прописать подсеть чисто для проброса, допустим 10.100.10.0/30, а на Микротике 2 подсеть 10.200.10.0/30.

А потом просто на Микротике №1 гонять трафик с подсети 10.100.10.0/30 в подсеть 10.10.3.0/24 в Офисе 1, а на Микротике №2 гонять трафик с подсети 10.200.10.0/30 в подсеть 10.10.3.0/24 в Офисе 2.

Сети 10.100.10.0/30 и 10.200.10.0/30 чисто для проброса. Они на LAN-интерфейсе. На том же LAN-интерфейсе прописаны адреса для Микротика №1 — 10.10.3.1, а для Микротика №2 — 10.10.3.250.

Подскажите, на верном ли я пути? Как проще объеденить посредством IPIP две одинаковые подсети. Иными словами, чтобы подсетку 10.10.3.0/24 "растянуть" между двумя офисами.

EoIP не предлагать! :-) Можете что-нибудь другое предложить
  • Вопрос задан
  • 749 просмотров
Пригласить эксперта
Ответы на вопрос 4
jamakasi666
@jamakasi666
Просто IT'шник.
Пожалуйста, можете страдать =) :
Роутер1:
типа тыкаем на "виртуальную подсеть"
/ip route add distance=1 dst-address=10.10.20.0/24 gateway=ваш-vpn-ip-роутер2
входящий трафик "типа виртуальной подсети" разворачиваем в реальную подсеть
/ip firewall nat add action=netmap chain=dstnat dst-address=10.10.10.0/24 to-addresses=10.10.3.0/24
исходящий трафик маскируем в типа "левую вируальную подсеть"
/ip firewall nat add action=netmap chain=srcnat src-address=10.10.3.0/24 out-interface=ваш-vpn-ip-роутер2 to-addresses=10.10.10.0/24

Роутер2:
/ip route add distance=1 dst-address=10.10.10.0/24 gateway=ваш-vpn-ip-роутер1
/ip firewall nat add action=netmap chain=dstnat dst-address=10.10.20.0/24 to-addresses=10.10.3.0/24
/ip firewall nat add action=netmap chain=srcnat src-address=10.10.3.0/24 out-interface=ваш-vpn-ip-роутер1 to-addresses=10.10.20.0/24

Работать будет, каждый роутер будет считать что общается с совершенно иной подсетью. На практике это колхоз и проще руки поотрывать тем кто не хочет привести в порядок свои подсети побив их на отдельные и по уму.
Ответ написан
@Wexter
MPLS/L2VPN в помощь
Ответ написан
@nApoBo3
У вас какая-то каша. Если вы хотите объеденить их l2 туннелем( тоннель в бридж ), то у вас не две подсети, а одна географически распределённая.
Если же у вас реально две одинаковые подсети, то ваша идея корректна. В каждой подсети вы маскирует( подменяет ) другу сеть, меняя в ней адреса, подставляя вместо нее виртуальную сеть, маршрутизируете эту сеть на другой роутер и там делаете обратное преобразование. Сделать это надо на двух концах туннеля, поскольку иначе у вас не будут проходить ответы.
Ответ написан
Maxlinus
@Maxlinus
я коне что сам за 1:1 mapping, как у же было предложено выше, но давно натыкался на вот эту статью
https://habr.com/ru/post/282858/
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы