@Corp_Habra_Clients

Ошибка архитектуры WSL?

Спустя время пользования WSL столкнулся с проблемой - нельзя использовать порты ниже 1024 и файлы конфигурации Apache2 и nginx не сразу обновляются. И если получить сертификат Let's Encrypt я ещё хоть как-то смог, то вот с двумя проблемами туго. Во первых - почему даже при запуске служб от root нельзя использовать порты ниже 1024, а во вторых - почему поле изменения конфигурации Apache2 и замены в нём порта, он всё равно пытается поднять сервер на 80 порту?Как решить проблемы?
  • Вопрос задан
  • 131 просмотр
Пригласить эксперта
Ответы на вопрос 2
@q2digger
сисадмин
WSL это Windows Subsystem for Linux , это не линукс, не настоящий линукс если угодно. Надо чтобы работало как в линуксе - ставьте линукс, а WSL обладает множеством ограничений, и сетевой стек это пожалуй один из главных.
Ответ написан
Radjah
@Radjah
> файлы конфигурации Apache2 и nginx не сразу обновляются.
Оба сервера есть в нативном варианте под Windows.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы