@ne555n

Роутер с OpenWrt — ненормальное поведение

Дано: роутер с OpenWrt на борту(TP-Link MR3020); ADSL-модем, раздающий инет через Wi-Fi - собственно, подымающий WLAN.
Задача: Настроить роутер как клиент с статическим ip как по кабелю, так и через Wi-Fi.
Проблемы: Конфиги ниже. Через Ethernet все работает. Но вот с подключением к WLAN-у проблемы. На роутере вайфай поднимается, ifconfig говорит, что девайсу присвоен корректный адрес(тот, что я прописал в конфиге). Но вот по сети за этим адресом ничто не пингуется/отзывается. В веб-морде модема, в списке подключенных к WLAN-у девайсов, появляется мой роутер(MAC-адрес тот же), но почему-то с ip 0.0.0.0
В чем дело?

Конфиги(частично):

network:
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option ifname 'eth0'
option netmask '255.255.255.0'
option proto 'static'
option ipaddr '192.168.1.5'

config interface 'wlan'
option proto 'static'
option ifname 'wlan0'
option netmask '255.255.255.0'
option ipaddr '192.168.1.6'
option gateway '192.168.1.1'
option dns '192.168.1.1'
wireless:
config wifi-iface
option device 'radio0'
option network 'wlan'
option mode 'sta'
option ssid 'имя домашней сети'
option encryption 'psk'
option key 'пароль от домашней сети'

192.168.1.1 - адрес модема, раздающего Wi-Fi
192.168.1.6 - предпочитаемый адрес для роутера
Интересно:
Если настроить роутер как dhcp-клиент по Wi-Fi, но присвоить static ip по кабелю - роутер получает ip от модема, но не отзывается/пингуется за этим адресом.
  • Вопрос задан
  • 5182 просмотра
Пригласить эксперта
Ответы на вопрос 4
как минимум, если надо иметь доступ в одну сеть как клиентским wi-fi так и кабелем в порту internet, надо сделать брайдж между интерфейсами
Ответ написан
@mayorovp
Я понял, в чем проблема. Блок настроек wlan разделяется между "проводом" и Wi-Fi, так ведь? Получается, что у двух сетевых интерфейсов должен быть одинаковый адрес. А так делать нельзя.

Надо либо поставить разные адреса для интерфейсов - либо отключать один из них при подключении кабеля автоматически. Первое проще...

Еще вариант - поставить проводной интерфейс в бридж с беспроводным, и назначить адрес всему мосту. Но тогда надо будет запретить транзитные пакеты между ними на уровне файервола - иначе привет кольцо!
Ответ написан
@mayorovp
Вероятно, проблема с модемом. Он может попросту не разрешать цепляться к своей беспроводной сети со статическими настройками...
Ответ написан
gbg
@gbg
Баянист. Тамада. Услуги.
Зачем вам статические адреса? Если хотите, чтобы IP не менялся, сделайте резервирование по MAC
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы