Чем грозит использование Wordpress на старой версии PHP 5.2.17 и как безболезненно обновиться на последнюю версию PHP/Wordpress?

Всем привет, на хостинге стоит старая версия PHP, и следовательно не обновляется WP до последней версии(+не ставятся желаемые плагины). Подскажите самый лучший алгоритм по исправлению данной проблемы. И какие косяки могут вылезти при обновлении PHP\WP? Сейчас для меня самые большие опасения в том, что сайт построен почти полностью на Visual Composer, и при обновлении на новую версию может что нибудь отрубится, либо плагин будет работать некорректно. Так как версия самого Composer тоже старая(причем даже не знаю, стоит ли там пиратка компосера, или фри версия с их офф сайта).
  • Вопрос задан
  • 303 просмотра
Решения вопроса 1
xEpozZ
@xEpozZ
Веб-разработчик
В старых версия:
1. Хуже производительность.
2. Присутствуют уязвимости, которые починили в новых версия.
3. Дальнейшая поддержка.
4. Отсутствие мотивации и желания писать на старых вещах (если позовете прогера в команду)
5. Нет фич, которые появились в новых версия
6. Поддержка вендоров старых версия. Как раз ваши плагины не становятся, потому что производитель сказал "использовать только с 7 версии", например.

Как обновиться? Пишите хостеру об обновлении пхп или смените хостинг
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы