Как сделать определенные манипуляции в Excel 2007?

Приветствую, особо и не пользовался экселем. Но теперь необходимо обработать данные определенным образом. Как я понимаю можно использовать язык VB. Но пока не разобрался как именно. Возможно, и не нужно, если то, что мне необходимо можно сделать и так. К сожалению данные выносить с определенной машины нельзя, так что только на ней и со старым спредшитом. И так

Есть 5 колонок, с большим количеством строк. Допустим первая колонка это айди. Оно повторяется, иногда встречается один раз иногда больше. Как мне удалить все строки КРОМЕ ТЕХ в которых айди встречается только 2 раза? Т.е. больше 1 меньше трех. А как где встречается 3,4 и тд?

Другой вопрос, есть 4 колонки, так же с большим количеством записей. Как удалить все записи кроме тех, у которых в определенной колонке есть определенный текст?

Спасибо
  • Вопрос задан
  • 131 просмотр
Пригласить эксперта
Ответы на вопрос 3
zamboga
@zamboga
job: #Запускаю стартапы за %; #Интернет-маркетинг
Есть 5 колонок, с большим количеством строк. Допустим первая колонка это айди. Оно повторяется, иногда встречается один раз иногда больше. Как мне удалить все строки КРОМЕ ТЕХ в которых айди встречается только 2 раза? Т.е. больше 1 меньше трех. А как где встречается 3,4 и тд?

1. Считаем, что у таблицы есть заголовки. В любую вспомогательную колонку в строке 2 вводим формулу:
=СЧЁТЕСЛИ(A:A;A2)
— формула ищет в столбце "А" сколько раз встретится значение ячейки А2

2. Протягиваем формулу вниз, т.е. для 3й строки будет =СЧЁТЕСЛИ(A:A;A3), дл 4й строки =СЧЁТЕСЛИ(A:A;A4) и тд.

3. Применяем фильтр по нашей вспомогательной колонке (значение ≠ 2) и получим все строки, ID которых встречается любое число раз, кроме 2х.

4. Удаляем ненужное.
.
.
.
есть 4 колонки, так же с большим количеством записей. Как удалить все записи кроме тех, у которых в определенной колонке есть определенный текст?

1. Использовать фильтр
2. Удалить
Ответ написан
@ClearAirTurbulence
1.
Как мне удалить все строки КРОМЕ ТЕХ в которых айди встречается только 2 раза?

Вопрос сформулирован некорректно. Возможно, в виду имелось
"Как мне удалить все строки КРОМЕ ТЕХ, айди которых встречается в таблице только 2 раза?"
Иначе вопрос не имеет смысла.

2.
есть 4 колонки, так же с большим количеством записей. Как удалить все записи кроме тех, у которых в определенной колонке есть определенный текст?


Автофильтр.
Выделяете таблицу, или ставите в любоее ее место курсор, если она непрерывна. Включаете автофильтр. Выставляете условие "не содержит строку" и вводите строку, которую должны содержать оставляемые строки. Остаются только ненужные строки. Выделяете их. Удаляете. Снимаете фильтр. Отображаются ранее скрытые им строки, содержащие строку.
Ответ написан
alexgearbox
@alexgearbox
Описанная во втором абзаце задачка интересная.

В гугл-таблице нужно удалять только те строки, в которых по столбцам Ch1, Ch3 и Ch4 содержится единица. Ch2 нужен для промежуточного расчёта. Данные в таблице должны быть сортированы по ID!
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы