@AlexanderSurik

Ошибка php-imap conflicts with file from package?

yum install php55-imap
spoiler
Loaded plugins: fastestmirror, replace
Setting up Install Process
Loading mirror speeds from cached hostfile
epel/metalink                                                                                                                                                                                                         |  26 kB     00:00
 * base: centosmirror.netcup.net
 * epel: mirror.imt-systems.com
 * extras: centosmirror.netcup.net
 * remi-php56: mirror.23media.de
 * rpmforge: mirror.de.leaseweb.net
 * updates: centosmirror.netcup.net
 * webtatic: uk.repo.webtatic.com
http://dl.atrpms.net/el6-x86_64/atrpms/stable/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host"
Trying other mirror.
base                                                                                                                                                                                                                  | 3.7 kB     00:00
centosup                                                                                                                                                                                                              | 2.9 kB     00:00
epel                                                                                                                                                                                                                  | 4.7 kB     00:00
epel/primary_db                                                                                                                                                                                                       | 6.0 MB     00:00
extras                                                                                                                                                                                                                | 3.4 kB     00:00
nginx                                                                                                                                                                                                                 | 2.9 kB     00:00
remi-php56                                                                                                                                                                                                            | 2.9 kB     00:00
rpmforge                                                                                                                                                                                                              | 1.9 kB     00:00
updates                                                                                                                                                                                                               | 3.4 kB     00:00
updates/primary_db                                                                                                                                                                                                    | 8.1 MB     00:00
webtatic                                                                                                                                                                                                              | 3.6 kB     00:00
Resolving Dependencies
--> Running transaction check
---> Package php55-imap.x86_64 0:5.5.28-1.el6 will be installed
--> Processing Dependency: php55-common(x86-64) = 5.5.28-1.el6 for package: php55-imap-5.5.28-1.el6.x86_64
--> Processing Dependency: libc-client.so.2007()(64bit) for package: php55-imap-5.5.28-1.el6.x86_64
--> Running transaction check
---> Package libc-client.x86_64 0:2007e-11.el6 will be installed
---> Package php55-common.x86_64 0:5.5.28-1.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================================================================================================================================================================================
 Package                                                     Arch                                                  Version                                                     Repository                                               Size
=============================================================================================================================================================================================================================================
Installing:
 php55-imap                                                  x86_64                                                5.5.28-1.el6                                                centosup                                                 51 k
Installing for dependencies:
 libc-client                                                 x86_64                                                2007e-11.el6                                                base                                                    515 k
 php55-common                                                x86_64                                                5.5.28-1.el6                                                centosup                                                1.2 M

Transaction Summary
=============================================================================================================================================================================================================================================
Install       3 Package(s)

 

Transaction Check Error:
  file /usr/lib64/php-zts/modules/bz2.so from install of php55-common-5.5.28-1.el6.x86_64 conflicts with file from package php55w-common-5.5.38-1.w6.x86_64
  file /usr/lib64/php/modules/bz2.so from install of php55-common-5.5.28-1.el6.x86_64 conflicts with file from package php55w-common-5.5.38-1.w6.x86_64
  file /usr/lib64/php-zts/modules/calendar.so from install of php55-common-5.5.28-1.el6.x86_64 conflicts with file from package php55w-common-5.5.38-1.w6.x86_64
  file /usr/lib64/php/modules/calendar.so from install of php55-common-5.5.28-1.el6.x86_64 conflicts with file from package php55w-common-5.5.38-1.w6.x86_64
  file /usr/lib64/php-zts/modules/ctype.so from install of php55-common-5.5.28-1.el6.x86_64 conflicts with file from package php55w-common-5.5.38-1.w6.x86_64
 
  ... и так далее



php -v
spoiler
PHP 5.5.38 (cli) (built: Jul 21 2016 12:51:12)
Copyright (c) 1997-2015 The PHP Group
Zend Engine v2.5.0, Copyright (c) 1998-2015 Zend Technologies
    with XCache v3.2.0, Copyright (c) 2005-2014, by mOo
    with XCache Cacher v3.2.0, Copyright (c) 2005-2014, by mOo



yum list installed | grep php
spoiler
php-pear-Auth-SASL.noarch            1.0.6-1.el6                       @epel
php-pear-Mail-Mime.noarch            1.8.4-1.el6                       @epel
php-pear-Mail-mimeDecode.noarch      1.5.5-1.el6                       @epel
php-pear-Net-IDNA2.noarch            0.1.1-3.el6                       @epel
php-pear-Net-SMTP.noarch             1.6.1-1.el6                       @epel
php-pear-Net-Sieve.noarch            1.3.4-1.el6                       @epel
php-pear-Net-Socket.noarch           1.0.10-1.el6                      @epel
php55w.x86_64                        5.5.38-1.w6                       @webtatic
php55w-cli.x86_64                    5.5.38-1.w6                       @webtatic
php55w-common.x86_64                 5.5.38-1.w6                       @webtatic
php55w-devel.x86_64                  5.5.38-1.w6                       @webtatic
php55w-fpm.x86_64                    5.5.38-1.w6                       @webtatic
php55w-gd.x86_64                     5.5.38-1.w6                       @webtatic
php55w-intl.x86_64                   5.5.38-1.w6                       @webtatic
php55w-ldap.x86_64                   5.5.38-1.w6                       @webtatic
php55w-mbstring.x86_64               5.5.38-1.w6                       @webtatic
php55w-mcrypt.x86_64                 5.5.38-1.w6                       @webtatic
php55w-mysql.x86_64                  5.5.27-1.w6                       @webtatic
php55w-pdo.x86_64                    5.5.38-1.w6                       @webtatic
php55w-pear.noarch                   1:1.9.4-7.w6                      @webtatic
php55w-pecl-memcache.x86_64          3.0.8-2.w6                        @webtatic
php55w-process.x86_64                5.5.38-1.w6                       @webtatic
php55w-pspell.x86_64                 5.5.38-1.w6                       @webtatic
php55w-soap.x86_64                   5.5.38-1.w6                       @webtatic
php55w-xml.x86_64                    5.5.38-1.w6                       @webtatic
phpmyadmin.noarch                    2.11.11.3-2.el6.rf                @rpmforge

  • Вопрос задан
  • 164 просмотра
Пригласить эксперта
Ответы на вопрос 1
@AlexanderSurik Автор вопроса
yum install php55w-common

spoiler
Loaded plugins: fastestmirror, replace
Setting up Install Process
Determining fastest mirrors
 * base: centosmirror.netcup.net
 * epel: mirror.imt-systems.com
 * extras: centosmirror.netcup.net
 * remi-php56: mirror.23media.de
 * rpmforge: mirror.de.leaseweb.net
 * updates: centosmirror.netcup.net
 * webtatic: uk.repo.webtatic.com
http://dl.atrpms.net/el6-x86_64/atrpms/stable/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host"
Trying other mirror.
Package php55w-common is obsoleted by php-common, trying to install php-common-5.6.36-1.el6.remi.x86_64 instead
Resolving Dependencies
--> Running transaction check
---> Package php-common.x86_64 0:5.6.36-1.el6.remi will be obsoleting
--> Processing Dependency: php-pecl-zip(x86-64) for package: php-common-5.6.36-1.el6.remi.x86_64
Package php-pecl-zip is obsoleted by php52-common, but obsoleting package does not provide for requirements
--> Processing Dependency: php-pecl-jsonc(x86-64) for package: php-common-5.6.36-1.el6.remi.x86_64
---> Package php55w-common.x86_64 0:5.5.38-1.w6 will be obsoleted
--> Processing Dependency: php(api) = 20121113 for package: php55w-pecl-memcache-3.0.8-2.w6.x86_64
--> Processing Dependency: php(zend-abi) = 20121212 for package: php55w-pecl-memcache-3.0.8-2.w6.x86_64
--> Processing Dependency: php-pecl-zip(x86-64) for package: php-common-5.6.36-1.el6.remi.x86_64
--> Processing Dependency: php55w-common(x86-64) = 5.5.38-1.w6 for package: php55w-ldap-5.5.38-1.w6.x86_64
--> Processing Dependency: php55w-common(x86-64) = 5.5.38-1.w6 for package: php55w-soap-5.5.38-1.w6.x86_64
--> Processing Dependency: php55w-common(x86-64) = 5.5.38-1.w6 for package: php55w-mbstring-5.5.38-1.w6.x86_64
 ......
--> Running transaction check
---> Package php.x86_64 0:5.6.36-1.el6.remi will be obsoleting
---> Package php-cli.x86_64 0:5.6.36-1.el6.remi will be obsoleting
---> Package php-common.x86_64 0:5.6.36-1.el6.remi will be obsoleting
---> Package php-fpm.x86_64 0:5.6.36-1.el6.remi will be obsoleting
---> Package php-gd.x86_64 0:5.6.36-1.el6.remi will be obsoleting
--> Processing Dependency: gd-last(x86-64) >= 2.1.1 for package: php-gd-5.6.36-1.el6.remi.x86_64
--> Processing Dependency: libgd.so.3()(64bit) for package: php-gd-5.6.36-1.el6.remi.x86_64
---> Package php-intl.x86_64 0:5.6.36-1.el6.remi will be obsoleting
--> Processing Dependency: libicuuc.so.50()(64bit) for package: php-intl-5.6.36-1.el6.remi.x86_64
--> Processing Dependency: libicuio.so.50()(64bit) for package: php-intl-5.6.36-1.el6.remi.x86_64
--> Processing Dependency: libicui18n.so.50()(64bit) for package: php-intl-5.6.36-1.el6.remi.x86_64
--> Processing Dependency: libicudata.so.50()(64bit) for package: php-intl-5.6.36-1.el6.remi.x86_64
---> Package php-ldap.x86_64 0:5.6.36-1.el6.remi will be obsoleting
---> Package php-mbstring.x86_64 0:5.6.36-1.el6.remi will be obsoleting
---> Package php-mcrypt.x86_64 0:5.6.36-1.el6.remi will be obsoleting
---> Package php-pdo.x86_64 0:5.6.36-1.el6.remi will be obsoleting
---> Package php-pecl-jsonc.x86_64 0:1.3.10-2.el6.remi.5.6 will be installed
---> Package php-process.x86_64 0:5.6.36-1.el6.remi will be obsoleting
---> Package php-pspell.x86_64 0:5.6.36-1.el6.remi will be obsoleting
---> Package php-soap.x86_64 0:5.6.36-1.el6.remi will be obsoleting
---> Package php-xml.x86_64 0:5.6.36-1.el6.remi will be obsoleting
---> Package php55-common.x86_64 0:5.5.28-1.el6 will be installed
---> Package php55w.x86_64 0:5.5.38-1.w6 will be obsoleted
.......
---> Package php55w-mcrypt.x86_64 0:5.5.38-1.w6 will be obsoleted
---> Package php55w-pdo.x86_64 0:5.5.38-1.w6 will be obsoleted
--> Processing Dependency: php55w-pdo(x86-64) for package: php55w-mysql-5.5.27-1.w6.x86_64
---> Package php55w-process.x86_64 0:5.5.38-1.w6 will be obsoleted
---> Package php55w-pspell.x86_64 0:5.5.38-1.w6 will be obsoleted
---> Package php55w-soap.x86_64 0:5.5.38-1.w6 will be obsoleted
---> Package php55w-xml.x86_64 0:5.5.38-1.w6 will be obsoleted
--> Running transaction check
---> Package php-devel.x86_64 0:5.6.36-1.el6.remi will be obsoleting
--> Processing Dependency: php-pecl-jsonc-devel(x86-64) for package: php-devel-5.6.36-1.el6.remi.x86_64
---> Package php-gd.x86_64 0:5.6.36-1.el6.remi will be obsoleting
--> Processing Dependency: gd-last(x86-64) >= 2.1.1 for package: php-gd-5.6.36-1.el6.remi.x86_64
--> Processing Dependency: libgd.so.3()(64bit) for package: php-gd-5.6.36-1.el6.remi.x86_64
---> Package php-intl.x86_64 0:5.6.36-1.el6.remi will be obsoleting
--> Processing Dependency: libicuuc.so.50()(64bit) for package: php-intl-5.6.36-1.el6.remi.x86_64
--> Processing Dependency: libicuio.so.50()(64bit) for package: php-intl-5.6.36-1.el6.remi.x86_64
--> Processing Dependency: libicui18n.so.50()(64bit) for package: php-intl-5.6.36-1.el6.remi.x86_64
--> Processing Dependency: libicudata.so.50()(64bit) for package: php-intl-5.6.36-1.el6.remi.x86_64
---> Package php-mysqlnd.x86_64 0:5.6.36-1.el6.remi will be obsoleting
---> Package php-pear.noarch 1:1.10.5-6.el6.remi will be obsoleting
--> Processing Dependency: php-composer(fedora/autoloader) for package: 1:php-pear-1.10.5-6.el6.remi.noarch
---> Package php55w-devel.x86_64 0:5.5.38-1.w6 will be obsoleted
---> Package php55w-mysql.x86_64 0:5.5.27-1.w6 will be obsoleted
---> Package php55w-pear.noarch 1:1.9.4-7.w6 will be obsoleted
--> Running transaction check
---> Package php-fedora-autoloader.noarch 0:1.0.0-1.el6 will be installed
---> Package php-gd.x86_64 0:5.6.36-1.el6.remi will be obsoleting
--> Processing Dependency: gd-last(x86-64) >= 2.1.1 for package: php-gd-5.6.36-1.el6.remi.x86_64
--> Processing Dependency: libgd.so.3()(64bit) for package: php-gd-5.6.36-1.el6.remi.x86_64
---> Package php-intl.x86_64 0:5.6.36-1.el6.remi will be obsoleting
--> Processing Dependency: libicuuc.so.50()(64bit) for package: php-intl-5.6.36-1.el6.remi.x86_64
--> Processing Dependency: libicuio.so.50()(64bit) for package: php-intl-5.6.36-1.el6.remi.x86_64
--> Processing Dependency: libicui18n.so.50()(64bit) for package: php-intl-5.6.36-1.el6.remi.x86_64
--> Processing Dependency: libicudata.so.50()(64bit) for package: php-intl-5.6.36-1.el6.remi.x86_64
---> Package php-pecl-jsonc-devel.x86_64 0:1.3.10-2.el6.remi.5.6 will be installed
--> Finished Dependency Resolution
Error: Package: php-intl-5.6.36-1.el6.remi.x86_64 (remi-php56)
           Requires: libicuuc.so.50()(64bit)
Error: Package: php-intl-5.6.36-1.el6.remi.x86_64 (remi-php56)
           Requires: libicudata.so.50()(64bit)
Error: Package: php-gd-5.6.36-1.el6.remi.x86_64 (remi-php56)
           Requires: gd-last(x86-64) >= 2.1.1
Error: Package: php-common-5.6.36-1.el6.remi.x86_64 (remi-php56)
           Requires: php-pecl-zip(x86-64)
           Removing: php55w-common-5.5.38-1.w6.x86_64 (@webtatic)
               php-pecl-zip(x86-64) = 1.11.0
           Obsoleted By: php-common-5.6.36-1.el6.remi.x86_64 (remi-php56)
               Not found
           Available: php-common-5.3.29-2.el6.x86_64 (centosup)
               php-pecl-zip(x86-64) = 1.11.0
           Available: php-pecl-zip-1.15.1-1.el6.remi.5.6.x86_64 (remi-php56)
               php-pecl-zip(x86-64) = 1.15.1-1.el6.remi.5.6
           Available: php-pecl-zip-1.15.2-1.el6.remi.5.6.x86_64 (remi-php56)
               php-pecl-zip(x86-64) = 1.15.2-1.el6.remi.5.6
           Available: php54-common-5.4.44-1.el6.x86_64 (centosup)
               php-pecl-zip(x86-64) = 1.11.0
           Available: php55-common-5.5.28-1.el6.x86_64 (centosup)
               php-pecl-zip(x86-64) = 1.11.0
           Available: php56-common-5.6.12-1.el6.x86_64 (centosup)
               php-pecl-zip(x86-64) = 1.12.5
           Available: php56w-common-5.6.33-1.w6.x86_64 (webtatic)
               php-pecl-zip(x86-64) = 1.12.5
           Available: php56w-common-5.6.34-1.w6.x86_64 (webtatic)
               php-pecl-zip(x86-64) = 1.12.5
           Available: php56w-common-5.6.35-1.w6.x86_64 (webtatic)
               php-pecl-zip(x86-64) = 1.12.5
           Available: php56w-common-5.6.36-1.w6.x86_64 (webtatic)
               php-pecl-zip(x86-64) = 1.12.5
           Available: php70w-common-7.0.27-1.w6.x86_64 (webtatic)
               php-pecl-zip(x86-64) = 1.13.5
           Available: php70w-common-7.0.28-1.w6.x86_64 (webtatic)
               php-pecl-zip(x86-64) = 1.13.5
           Available: php70w-common-7.0.29-1.w6.x86_64 (webtatic)
               php-pecl-zip(x86-64) = 1.13.5
           Available: php70w-common-7.0.30-1.w6.x86_64 (webtatic)
               php-pecl-zip(x86-64) = 1.13.5
           Available: php71w-common-7.1.13-1.w6.x86_64 (webtatic)
               php-pecl-zip(x86-64) = 1.13.5
           Available: php71w-common-7.1.14-1.w6.x86_64 (webtatic)
               php-pecl-zip(x86-64) = 1.13.5
           Available: php71w-common-7.1.15-1.w6.x86_64 (webtatic)
               php-pecl-zip(x86-64) = 1.13.5
           Available: php71w-common-7.1.16-1.w6.x86_64 (webtatic)
               php-pecl-zip(x86-64) = 1.13.5
           Available: php71w-common-7.1.17-1.w6.x86_64 (webtatic)
               php-pecl-zip(x86-64) = 1.13.5
           Available: php-common-5.3.3-49.el6.x86_64 (base)
               Not found
           Available: php-common-5.6.35-1.el6.remi.x86_64 (remi-php56)
               Not found
Error: Package: php-intl-5.6.36-1.el6.remi.x86_64 (remi-php56)
           Requires: libicuio.so.50()(64bit)
Error: Package: php-intl-5.6.36-1.el6.remi.x86_64 (remi-php56)
           Requires: libicui18n.so.50()(64bit)
Error: Package: php-gd-5.6.36-1.el6.remi.x86_64 (remi-php56)
           Requires: libgd.so.3()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы