Почему не устанавливается php?

В принципе не только связано с php но и mariaDB такая да и еще с другими программами, допустим с skype и так далее, но не суть
У меня выходит вот такая ошибка
ruslan@debian:~/Загрузки$ sudo apt-get install php7.0    
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 php7.0 : Зависит: libapache2-mod-php7.0 но он не будет установлен или
                          php7.0-fpm но он не будет установлен или
                          php7.0-cgi но он не будет установлен
          Зависит: php7.0-common но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

Пробовал делать update, upgrade -f install но ничего не помогает, в чем кроется ошибка?
  • Вопрос задан
  • 499 просмотров
Решения вопроса 1
@AVKor
Сломана пакетная база.

Обычно происходит, когда в источники пакетов суют всякое левое дерьмо.

Убирайте левак из источников и обновляйте пакетную базу.
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы