Как установить библиотеку vkcom/vk-php-sdk?

Здравствуйте. У меня проблема:
Выполнил установку composer, выполнил установку vkcom/vk-php-sdk командой composer-php7.1 require vkcom/vk-php-sdk проинклудил require_once __DIR__ . '/vendor/autoload.php';

Но ничего не работает. При создании объекта
$vk = new VKApiClient();


Выдает ошибку:
Fatal error: require_once(): Failed opening required


Что я не так делаю? В мануале написано просто установить и создать объект. Ничего лишнего нет =(

Писал в тех.поддержку VK, мне ответили что они не сильно разбираются в их библиотеках...
  • Вопрос задан
  • 1075 просмотров
Пригласить эксперта
Ответы на вопрос 1
@LazyDev
  1. Проверьте наличие /vendor/autoload.php
  2. Проверьте права доступа на чтение файла autoload
  3. Если скрипт, в котором инклудится autoload лежит не рядом с директорией vendor, пропишите абсолютный путь к файлу
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы