chumayu
@chumayu
Если в башне по*бень. То что еб*нь, что не еб*нь.

Mikrotik, автоматическое назначение разных DNS серверов?

Добрый,

как реализовать на микротике назначение разных DNS серверов в предалах одной сети?

Пример:

Два компа в одной сети у одного ДНС 8.8.8.8,у второго ДНС 127.127.127.127
  • Вопрос задан
  • 7153 просмотра
Решения вопроса 1
westex
@westex
net
В разделе DHCP сервера создаете опцию
/ip dhcp-server option
add code=6 name=Local value="'127.127.127.127'"
add code=6 name=Google value="'8.8.8.8'"

f1c07525b24445fe9ce15ec79d7eab1d.PNG

Создаете статическую лизу для нужного хоста. Для каждого хоста нужно указать DHCP options.
7b71c55fefdb453f83c5e1f99df34f3d.PNG

Если нужно выдавать по несколько разных DNS (как правило основной + резерв). То создаете несколько опций для каждого DNS по отдельности. Добавляете их в options set нужный "набор".
В статической лизе вместо DHCP options выбираете DHCP Oprions Set нужный вами набор.
Ответ написан
Пригласить эксперта
Ответы на вопрос 2
@LiS-31
Приведите пример зачем вам это потребовалось?
Стандартными средствами это сделать не возможно, предполагается, что все ДНС возвращают одинаковые значения и различий между ними нет.
Максимум что можно сделать: создать 2 DHCP POOL и развести их по интерфейсам, или vlan.
Ответ написан
@satoo
Если не вдаваться в подробности, для чего автору это надо, то можно
  • По dhcp выдавать разные dns-сервера
    ip dhcp-server network add address=x.x.x.x/32 dns-server=8.8.8.8 gateway=y.y.y.y

  • Выдать одинаковые dns-сервера, но в нате на анализе источника перекидываеть на нужный сервер

Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы