sajor2006
@sajor2006
Ну я человек. )

Как настроить bird ospf?

Драсте, помогите не получается настроить ospf на bird4. (сильно не бейте, я протокол ospf знаю только пару дней)
настраиваю тестовый стенд.
Дано:
сеть 10.5.0.0/22
три машины, на двух стоит quagga, на одной bird4.

две quaggИ видят друг друга, а вот bird ни кого не видит и его не видно.
iptables чист.

конфиги:

quagga /etc/quagga/ospfd.conf
!
! Zebra configuration saved from vty
!   2017/09/05 11:13:37
!
hostname ospfd
password zebra
log stdout
log file /var/log/quagga/ospfd.log
!
!
!
interface enp0s3
ip ospf hello-interval 1
!
interface lo
!
interface tap0
!
router ospf
 ospf router-id 10.5.0.2
 network 10.5.0.0/22 area 0.0.0.0
 neighbor 10.5.0.3
!
line vty
!

[root@router1 quagga]# cat /etc/quagga/zebra.conf 
!
! Zebra configuration saved from vty
!   2017/09/05 11:13:37
!
hostname Router
password zebra
enable password zebra
log file /var/log/quagga/quagga.log
!
interface enp0s3
 description LAN
 ip address 172.17.1.79/24
 ipv6 nd suppress-ra
!
interface lo
 description loopback
 ip address 127.0.0.1/8
!
interface tap0 
 description VPN
 ip address 10.5.0.2/22
 ipv6 nd suppress-ra
!
ip forwarding
!
!
interface enp0s3
 ip route 0.0.0.0/0 172.17.1.1
!
line vty
!


root@OpenWrt:~# cat /etc/bird4.conf
log syslog all;
router id 10.5.0.4;

protocol kernel {
        export all;
        scan time 15;
};

protocol ospf  test {
        import all;
        export all;
	
        area 0.0.0.0 {
	networks {
		10.5.0.0/22;	
		};
                interface "tap0" {
                        cost 1;
                        hello 5;
                        priority 100;
                        dead 10;
			type bcast;
                        authentication none;
                        #password "zebra";
                };
         };
};
  • Вопрос задан
  • 3159 просмотров
Решения вопроса 1
karabanov
@karabanov Куратор тега Linux
Системный администратор
Необходимо убедится, что таймеры hello, dead и т.д. совпадают.
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы