Machez
@Machez
Бу!

Как устранить ошибку при установки ImageMagick для PHP 7 на CentOS 7?

Есть сервер под управлением CentOS 7. На нем установлен PHP 7. Но есть артефакты от предыдущих версий PHP. И вот проблемка.

Выполняю команду...

yum install ImageMagick ImageMagick-devel

...всё отлично, идём дальше и выполняем команду установки пакета php-pear...

yum install gcc php-devel php-pear

...и процесс установки завершается ошибкой...

[root@VM-4169-16029-01 ~]# yum install gcc php-devel php-pear 
Loaded plugins: fastestmirror, replace 
Loading mirror speeds from cached hostfile 
* base: mirror.logol.ru 
* extras: mirror.logol.ru 
* updates: mirror.logol.ru 
* webtatic: uk.repo.webtatic.com 
Resolving Dependencies 
--> Running transaction check 
---> Package gcc.x86_64 0:4.8.5-4.el7 will be installed 
--> Processing Dependency: cpp = 4.8.5-4.el7 for package: gcc-4.8.5-4.el7.x86_64 
--> Processing Dependency: glibc-devel >= 2.2.90-12 for package: gcc-4.8.5-4.el7.x86_64 
--> Processing Dependency: libmpfr.so.4()(64bit) for package: gcc-4.8.5-4.el7.x86_64 
--> Processing Dependency: libmpc.so.3()(64bit) for package: gcc-4.8.5-4.el7.x86_64 
---> Package php-devel.x86_64 0:5.4.16-36.3.el7_2 will be installed 
--> Processing Dependency: php-cli(x86-64) = 5.4.16-36.3.el7_2 for package: php-devel-5.4.16-36.3.el7_2.x86_64 
---> Package php-pear.noarch 1:1.9.4-21.el7 will be installed 
--> Running transaction check 
---> Package cpp.x86_64 0:4.8.5-4.el7 will be installed 
---> Package glibc-devel.x86_64 0:2.17-106.el7_2.8 will be installed 
--> Processing Dependency: glibc-headers = 2.17-106.el7_2.8 for package: glibc-devel-2.17-106.el7_2.8.x86_64 
--> Processing Dependency: glibc-headers for package: glibc-devel-2.17-106.el7_2.8.x86_64 
---> Package libmpc.x86_64 0:1.0.1-3.el7 will be installed 
---> Package mpfr.x86_64 0:3.1.1-4.el7 will be installed 
---> Package php-cli.x86_64 0:5.4.16-36.3.el7_2 will be installed 
--> Processing Dependency: php-common(x86-64) = 5.4.16-36.3.el7_2 for package: php-cli-5.4.16-36.3.el7_2.x86_64 
--> Running transaction check 
---> Package glibc-headers.x86_64 0:2.17-106.el7_2.8 will be installed 
--> Processing Dependency: kernel-headers >= 2.2.1 for package: glibc-headers-2.17-106.el7_2.8.x86_64 
--> Processing Dependency: kernel-headers for package: glibc-headers-2.17-106.el7_2.8.x86_64 
---> Package php-common.x86_64 0:5.4.16-36.3.el7_2 will be installed 
--> Running transaction check 
---> Package kernel-headers.x86_64 0:3.10.0-327.36.2.el7 will be installed 
--> Processing Conflict: php70w-common-7.0.12-1.w7.x86_64 conflicts php-common < 7.0 
--> Finished Dependency Resolution 
Error: php70w-common conflicts with php-common-5.4.16-36.3.el7_2.x86_64 
You could try using —skip-broken to work around the problem 
You could try running: rpm -Va —nofiles —nodigest


1d07ee7d64b1431fb03019b1c6e4807e.png

Я не очень силён в администрировании... Подскажите как решить возникшую проблемку. Я так понимаю надо удалить php 5.4 и только потом выполнить установку php-pear?
  • Вопрос задан
  • 572 просмотра
Решения вопроса 1
yum install gcc php70w-pear php70w-devel
Вы пытаетесь поставить php 5.4 а уже стоит 7.0
Ответ написан
Пригласить эксперта
Ответы на вопрос 1
Error: php70w-common conflicts with php-common-5.4.16-36.3.el7_2.x86_64
ну вот же пишет об этом yum. Вячеслав Рахинский вам уже ответил что делать
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы