@SierraMadre

Как сделать бесшовный wi-fi?

Добрый день, Хочу сделать дома бесшовный WiFi, подскажите пожалуйста что для этого нужно, на данный момент есть роутер MikroTik haplite RB 941 и роутер d-link dir-300 Я так понимаю что этого недостаточно для осуществление этой цели.
  • Вопрос задан
  • 5330 просмотров
Пригласить эксперта
Ответы на вопрос 5
@paxlo
докупить любых самых дешевых микротиков, установить на все роутеры пакет capsman2, на центральном роутере поднять контроллер, остальные чтобы забирали с контроллера всю инфу. Пример:
Контроллер:
/caps-man interface rem [find]
/caps-man channel
add band=2ghz-b/g/n extension-channel=Ce frequency=2412 name=channel1 tx-power=13 width=20
/caps-man datapath
add bridge=bridge-local client-to-client-forwarding=yes name=datapath1
/caps-man security
add authentication-types=wpa2-psk encryption=aes-ccm name=sec1 passphrase="пароль"
/caps-man configuration
add country=russia datapath=datapath1 hide-ssid=no mode=ap name=cfg1 security=sec1 ssid=имя _сети channel=channel1
/caps-man provisioning
add action=create-dynamic-enabled master-configuration=cfg1
/caps-man manager
set enabled=yes
/interface wireless cap
set bridge=bridge-local caps-man-addresses=127.0.0.1 discovery-interfaces=bridge-local enabled=yes interfaces=wlan1


На остальных точках удаляем свои dhcp и говорим им получать все с центрального:
/ip dhcp-server rem [find]
/ip dhcp-server network rem [find]
/ip pool rem [find]
/ip dhcp-client set 0 interface=bridge0 disabled=no
/interface wireless cap
set bridge=bridge0 discovery-interfaces=bridge0 enabled=yes interfaces=wlan1
Ответ написан
@silverjoe
Ubiquiti
вроде почти бесшовный :)
Там продавался комплект из 3 точек потолочных
Ответ написан
Комментировать
@moneron89
Сертифицированный тренер Mikrotik
Поставьте на микротик пакет wireless-rep и поднимите на нём репитер. Вот вам и расширение зоны покрытия
Ответ написан
Комментировать
SergeySL
@SergeySL
Системный администратор
Расширение зоны покрытия, для которого достаточно репитеров, и роуминг (бесшовное покрытие) - разные вещи. При роуминге не рвется соединение, когда клиент переключается между точками, но это другие деньги. В свое время делали такое на D-Link'ах DWS-3024 (коммутатор) и DWL-8500AP (точки). На тот момент это было самое дешевое решение.
Ответ написан
Комментировать
@satoo
1. Бесшовный роуминг как понятие отсутствует в стандарте wifi. Каждый производитель решает данную задачу по-своему
2. Микротик имеет возможность настройки по сбрасыванию клиента, когда уровень его сигнала ниже заданного, что решает следующую стандартную ситуацию:
  • wifi клиент держится за точку "до конца";
  • "конец", зачастую, означает крайне низкий уровень сигнала, когда даже пользователь видит, что часть пакетов теряется, но на канальном уровне линк еще висит. Как в телефоне, значок "Е" горит, но интернета уже нет (это уже не интернет :))


Сбрасывание клиента, у которого уровень сигнала ниже заданного приводит:

  • к переподключению клиента к ssid аналогичному последнему;
  • при наличии точки, вещающей аналогчиный ssid выбирается точка с большим уровнем сигнала;
  • таким образом происходит "роуминг" клиента микротика - мы сбрасываем клиента и заставляем его найти точку с большим уровнем сигнала в то время, когда беспроводной линк еще "живой", но уже начинает "лагать"


Мы проектировали сеть на микротиках так, что копирование файла, при перемещении между точками доступа не прерывалось (голос и пр - аналогично). Но, вообще, никто не сможет гарантировать полное отсутствие потерь пакетов при переходе между точками - нет единого стандарта.

ЗЫЖ в качестве аллегории wifi можно описать так: точка доступа - комната, абоненты - люди разговаривающие в комнате. Есть правило: в комнате может разговаривать в одно время только один человек.

Если комната большая, то возможна ситуация, когда человек, находящийся в дальнем конце комнаты не слышит, что кто-то уже говорит и начинает сам говорить. Через какое-то время все понимают, что правило нарушено и замолкают. Затем ситуация может повториться (из-за тугого уха - не чувствительный приемник, из-за шепелявого говора - плохого тракта на передачу или на прием) - в итоге скорость сети будет падать.

Все wifi репитеры, которые слушают wifi и его повторяют есть зло, т.к. в таком случае в конце комнаты стоит другой человек который повторяет каждой комнате то, что слышит в другой (причем он повторяет все - и глухих и шепелявых). Из-за этого резко возрастает количество коллизий - нарушения правила - в одно время вещает только одно устройство.

ИТОГ: для увеличения покрытия зоны wifi правильно использовать только провод.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы