@Fi3xeR

Произвольное отключение клиентов Wi-Fi?

Здравствуйте. Имеется RB Groove A-52HPn с антенной кругового излучения AX-2411R. Установлен на высоте около 10 метров практически в чистом поле в нескольких километрах от города (коттеджный поселок), помехи практически отсутствуют (если надо, могу сделать анализ частот).
К этому Микротику по Wi-Fi подключаются разные клиенты (роутеры, ноутбуки, планшеты и т.д.), и у них всех одновременно периодически обрывается связь. Потом связь появляется, потом снова обрывается и так далее. Причем соединение может работать стабильно на протяжении суток и более, а потом неожиданно и без какого-либо вмешательства администратора или внешних причин снова перейти в режим коннект-дисконнект.
Настройки Микротика - элементарные, авторизация всех подряд без пароля и просто в режиме бриджа передать информацию в LAN.
Я бы предположил, что это неисправность данного конкретного Микротика, но на некотором расстоянии от него (порядка километра) установлен точно такой же Микротик (запитанный уже совершенно от другой линии), который совершенно также настроен (кроме частоты беспроводного канала, названия беспроводной сети и IP-адреса), с которым творится аналогичная херня.
Из логов видно, что происходит постоянная потеря соединения, но при этом сигнал клиентов не такой уж и низкий, от -55 до -80 Дб.

Лог и настройки приложил ниже.

SYSTEM
[admin@MikroTik] > export
# dec/10/2015 10:58:20 by RouterOS 6.33.3
# software id = HEG4-ENPB
#
/interface bridge
add l2mtu=1600 name=bridge1
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g basic-rates-a/g=9Mbps \
basic-rates-b="" disabled=no frequency=2422 hw-protection-mode=rts-cts \
hw-retries=15 l2mtu=2290 mode=ap-bridge periodic-calibration-interval=10 \
radio-name=AlexNet-1 rate-set=configured ssid=AlexNet-1 \
supported-rates-a/g=9Mbps,12Mbps,18Mbps,24Mbps,36Mbps supported-rates-b="" \
tx-power=20 tx-power-mode=all-rates-fixed wireless-protocol=802.11
/interface wireless nstreme
set wlan1 enable-polling=no
/interface vlan
add interface=ether1 l2mtu=1596 name=vlan10 vlan-id=
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive
mac-cookie-timeout=3d
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=wlan1
/ip address
add address=192.168.0.11/24 interface=vlan10 network
/ip route
add distance=1 gateway=192.168.0.1
/ip upnp
set allow-disable-external-interface=no
/system clock manual
set time-zone=+03:00
/system leds
set 0 interface=wlan1
/system logging
add topics=!packet
/system ntp client
set enabled=yes mode=unicast primary-ntp=62.76.96.4
/system routerboard settings
set cpu-frequency=600MHz
[admin@MikroTik] >

=============================
LOG

08:18:44 route,debug,event status=UP,RUNNING
08:18:44 route,debug,event mtu=1500
08:18:44 route,debug,calc Begin calculation
08:18:44 route,debug,event Link up
08:18:44 route,debug,event interface=wlan1
08:18:44 route,debug,event Update
08:18:44 route,debug,event interface=wlan1
08:18:44 route,debug,calc End calculation
08:19:07 wireless,info E8:DE:27:9D:3B:E1@wlan1: disconnected, extensive data loss
08:19:10 route,debug,event Interface change
08:19:10 route,debug,event interface=wlan1
08:19:10 route,debug,event status=UP
08:19:10 route,debug,event mtu=1500
08:19:10 route,debug,calc Begin calculation
08:19:10 route,debug,event Link down
08:19:10 route,debug,event interface=wlan1
08:19:10 route,debug,event Update
08:19:10 route,debug,event interface=wlan1
08:19:10 route,debug,calc End calculation
08:23:52 wireless,info wlan1: data from unknown device 64:70:02:F7:F6:7F, sent dea
uth
08:23:54 wireless,debug wlan1: 64:70:02:F7:F6:7F attempts to associate
08:23:54 wireless,debug wlan1: 64:70:02:F7:F6:7F not in local ACL, by default acce
pt
08:23:54 wireless,info 64:70:02:F7:F6:7F@wlan1: connected
08:23:54 route,debug,event Interface change
08:23:54 route,debug,event interface=wlan1
08:23:54 route,debug,event status=UP,RUNNING
08:23:54 route,debug,event mtu=1500
08:23:55 route,debug,calc Begin calculation
08:23:55 route,debug,event Link up
08:23:55 route,debug,event interface=wlan1
08:23:55 route,debug,event Update
08:23:55 route,debug,event interface=wlan1
08:23:55 route,debug,calc End calculation
08:23:55 wireless,info wlan1: data from unknown device E8:DE:27:9D:3B:E1, sent dea
uth
08:23:58 wireless,debug wlan1: E8:DE:27:9D:3B:E1 attempts to associate
08:23:58 wireless,debug wlan1: E8:DE:27:9D:3B:E1 not in local ACL, by default acce
pt
08:23:58 wireless,info E8:DE:27:9D:3B:E1@wlan1: connected
08:24:18 wireless,info 64:70:02:F7:F6:7F@wlan1: disconnected, extensive data loss
08:24:21 wireless,info E8:DE:27:9D:3B:E1@wlan1: disconnected, extensive data loss
08:24:24 route,debug,event Interface change
08:24:24 route,debug,event interface=wlan1
08:24:24 route,debug,event status=UP
08:24:24 route,debug,event mtu=1500
08:24:24 route,debug,calc Begin calculation
08:24:24 route,debug,event Link down
08:24:24 route,debug,event interface=wlan1
08:24:24 route,debug,event Update
08:24:24 route,debug,event interface=wlan1
08:24:24 route,debug,calc End calculation
08:25:44 wireless,info wlan1: data from unknown device E8:DE:27:9D:3B:E1, sent dea
uth
08:25:46 wireless,debug wlan1: E8:DE:27:9D:3B:E1 attempts to associate
08:25:46 wireless,debug wlan1: E8:DE:27:9D:3B:E1 not in local ACL, by default acce
pt
08:25:46 wireless,info E8:DE:27:9D:3B:E1@wlan1: connected
08:25:46 route,debug,event Interface change
08:25:46 route,debug,event interface=wlan1
08:25:46 route,debug,event status=UP,RUNNING
08:25:46 route,debug,event mtu=1500
08:25:46 route,debug,calc Begin calculation
08:25:46 route,debug,event Link up
08:25:46 route,debug,event interface=wlan1
08:25:46 route,debug,event Update
08:25:46 route,debug,event interface=wlan1
08:25:46 route,debug,calc End calculation
08:26:09 wireless,info E8:DE:27:9D:3B:E1@wlan1: disconnected, extensive data loss
08:26:12 route,debug,event Interface change
08:26:12 route,debug,event interface=wlan1
08:26:12 route,debug,event status=UP
08:26:12 route,debug,event mtu=1500
08:26:13 route,debug,calc Begin calculation
08:26:13 route,debug,event Link down
08:26:13 route,debug,event interface=wlan1
08:26:13 route,debug,event Update
08:26:13 route,debug,event interface=wlan1
08:26:13 route,debug,calc End calculation
08:27:44 wireless,info wlan1: data from unknown device E8:DE:27:9D:3B:E1, sent dea
uth
08:27:47 wireless,debug wlan1: E8:DE:27:9D:3B:E1 attempts to associate
08:27:47 wireless,debug wlan1: E8:DE:27:9D:3B:E1 not in local ACL, by default acce
pt
08:27:47 wireless,info E8:DE:27:9D:3B:E1@wlan1: connected
08:27:47 route,debug,event Interface change
08:27:47 route,debug,event interface=wlan1
08:27:47 route,debug,event status=UP,RUNNING
08:27:47 route,debug,event mtu=1500
08:27:47 route,debug,calc Begin calculation
08:27:47 route,debug,event Link up
08:27:47 route,debug,event interface=wlan1
08:27:47 route,debug,event Update
08:27:47 route,debug,event interface=wlan1
08:27:47 route,debug,calc End calculation
08:27:52 wireless,info wlan1: data from unknown device 64:70:02:F7:F6:7F, sent dea
uth
08:28:10 wireless,info E8:DE:27:9D:3B:E1@wlan1: disconnected, extensive data loss
08:28:13 route,debug,event Interface change
08:28:13 route,debug,event interface=wlan1
08:28:13 route,debug,event status=UP
08:28:13 route,debug,event mtu=1500
08:28:14 route,debug,calc Begin calculation
08:28:14 route,debug,event Link down
08:28:14 route,debug,event interface=wlan1
08:28:14 route,debug,event Update
08:28:14 route,debug,event interface=wlan1
08:28:14 route,debug,calc End calculation
08:29:42 wireless,debug wlan1: 64:70:02:F7:F6:7F attempts to associate
08:29:42 wireless,debug wlan1: 64:70:02:F7:F6:7F not in local ACL, by default acce
pt
08:29:42 wireless,info 64:70:02:F7:F6:7F@wlan1: connected
08:29:42 route,debug,event Interface change
08:29:42 route,debug,event interface=wlan1
08:29:42 route,debug,event status=UP,RUNNING
08:29:42 route,debug,event mtu=1500
08:29:42 route,debug,calc Begin calculation
08:29:42 route,debug,event Link up
08:29:42 route,debug,event interface=wlan1
08:29:42 route,debug,event Update
08:29:42 route,debug,event interface=wlan1
08:29:42 route,debug,calc End calculation
08:29:44 wireless,info wlan1: data from unknown device E8:DE:27:9D:3B:E1, sent dea
uth
08:29:48 wireless,debug wlan1: E8:DE:27:9D:3B:E1 attempts to associate
08:29:48 wireless,debug wlan1: E8:DE:27:9D:3B:E1 not in local ACL, by default acce
pt
08:29:48 wireless,info E8:DE:27:9D:3B:E1@wlan1: connected
08:30:05 wireless,info 64:70:02:F7:F6:7F@wlan1: disconnected, extensive data loss
08:30:11 wireless,info E8:DE:27:9D:3B:E1@wlan1: disconnected, extensive data loss
08:30:14 route,debug,event Interface change
08:30:14 route,debug,event interface=wlan1
08:30:14 route,debug,event status=UP
08:30:14 route,debug,event mtu=1500
08:30:14 route,debug,calc Begin calculation
08:30:14 route,debug,event Link down
08:30:14 route,debug,event interface=wlan1
08:30:14 route,debug,event Update
08:30:14 route,debug,event interface=wlan1
08:30:14 route,debug,calc End calculation
08:30:35 ntp,debug Wait for 900 seconds before sending next message
08:30:35 ntp,debug gradually adjust by -1ca8fa
08:31:44 wireless,info wlan1: data from unknown device E8:DE:27:9D:3B:E1, sent dea
uth

[admin@MikroTik] >
  • Вопрос задан
  • 4556 просмотров
Пригласить эксперта
Ответы на вопрос 4
@moneron89
Сертифицированный тренер Mikrotik
Не следует забывать, что wifi - сеть коллизионная. Если клиенты начинают вещать одновременно - ни к чему хорошему это не приводит. Также распространена проблема скрытого узла (hidden node). Решение - использовать поллинговые или tdma протоколы. Но у микротика они свои, проприеритарные. Если у вас в посёлке достаточно много клиентов - лучше каждому из них установить что-то типа SXT lite2 или lite5 в режиме бриджа, в зависимости от используемой частоты на груве. Далее у каждого клиента дома роутер с его собственным вайфаем., При такой топологии (точка-мультиточка) настраивайте либо протокол NStreme либо NV2. У каждого из них есть преимущества и недостатки. Но при их использовании именно точка управляет передачей данных с клиентов, не позволяя им вещать одновременно. Да, затраты больше, чем просто воткнуть одну точку на огромную площадь, влупить ей 20 dBm + ещё антенну на 6 dBi и поджаривать ею пролетающих галок. Но зато будет работать. Если прозрачность между клиентами нужна - не сильно сложнее будет её настроить.
Ответ написан
@sweetbrick
У вас там фигурируют всякие "unknown device"(
Полагаю, вас ломают-с(
Запустите под вином сканер акрилик www.acrylicwifi.com.
Без всяких логов графическое представление по каналам/по времени с оценкой уровня сигнала и прочее...
В принципе, для захвата х/шейка достаточно один раз раз разорвать коннект с клиентом.
Это работают mdk3, Athrophy (?) , и еше одна софтина(не вспомню на вскидку).
Как вариант, у вас включен wps с блокировкой ассоциации после N неудачных пинов. Для ее (точки доступа) сброса (ребута) и применяются эти софтины. По идее микротик не должен был бы так вестись, но... кагрица хз(
Попробуйте сделать открытую гостевую подсеть с которой дайте только wan.
Простое отключение wps ничего не даст, в смысле вашим клиентам доступ в нет) через перманентно ребутящийся роутер - просто брокер))) будет валить тд вотместку(
Не жадничайте) Вообще это ммм... бывает, кароче. Особенно, когда чужие тд глушат/давят сигнал чей-то рабочей(
писи
уупс(
перечитал, и увидел "без пароля".
Вопрос не в заполненном знаками или пустом поля пароля, а в выбранном шифровании.
Правда не скажу, пропустит ли микротик пустое поле пароля на доступ в сеть, другие роутеры с пустым паролем попадались только в админку)
Ответ написан
Комментировать
@Fi3xeR Автор вопроса
Спасибо за ответ!
Не совсем понял, о каком шифровании идет речь. Пароля нет, шифрования нет, все настройки Микротика видны в шапке темы.
Основная сложность для диагностики причин возникновения дисконнектов заключается в том, что проблема возникает спонтанно. Периодически, и даже часто, все работает как надо. То есть клиенты могут продержаться без единого отключения больше суток, а потом, например, в течение двух-трех часов начинают поголовно отключаться/подключаться. Потом, на 500-й раз подключений, Микротик вдруг подключает всех и снова все работает как нужно. Это кошмар какой-то :(
Ответ написан
@Wolf_ktl
Сисадмин, Микротик MTCNA, MTCRE
Обнови прошивку до 6.35
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы
18 мая 2022, в 00:48
3000 руб./за проект
18 мая 2022, в 00:31
100000 руб./за проект
18 мая 2022, в 00:09
15000 руб./за проект