gluck59
@gluck59
Виртуальный глюк

Существует ли чекер старых php-скриптов на совместимость с 5.5...5.6?

Понадобилось обновить php с 5.4 до 5.5 минимум.

Существует ли в природе такой инструмент, в который можно было бы загрузить старые скрипты и он бы выдал что именно у вас тут deprecated и все такое?

Вручную я застрелюсь, их тут добрая сотня...
  • Вопрос задан
  • 164 просмотра
Пригласить эксперта
Ответы на вопрос 3
alexey-m-ukolov
@alexey-m-ukolov Куратор тега PHP
Да вы grep'ом можете посмотреть, быстрее будет, чем какой-то чекер искать. А учитывая количество несовместимых изменений и deprecated features, вероятность того, что кто-то такой чекер писал очень мала.
P.S. Последовательные переходы с 5.3 на 5.4, потом на 5.5 и 5.6 не вызвали вообще никаких проблем ни на одном из наших проектов.
Ответ написан
opium
@opium
Просто люблю качественно работать
ну простым скриптом в цикле прогнать запуск всех криптов в консоли и сохранить иррорлог отчеты
5.4 у меня все вообще гладко обновилось до 5.5, как то там не такие глобальные изменения по сравнению с версиями <=5.3
Ответ написан
Ranwise
@Ranwise
phpstorm подсвечивало deprecated
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы