CanVas
@CanVas
Веб-мастер

Как решить ошибку WordPress при добавлении мультисайта?

WordPress 4.2.2.
Включаем режим мультисайт - всё ок, полёт нормальный. Хостер всё запилил по настройкам.
Пытаемся добавить сайт, и получаем вот такое:

Warning: preg_match() expects parameter 2 to be string, object given in /home1/xxx/public_html/wp-includes/formatting.php on line 3435

Warning: preg_match() expects parameter 2 to be string, object given in /home1/xxx/public_html/wp-includes/formatting.php on line 3424

Warning: preg_match() expects parameter 2 to be string, object given in /home1/xxx/public_html/wp-includes/formatting.php on line 3435

Warning: strip_tags() expects parameter 1 to be string, object given in /home1/xxx/public_html/wp-includes/formatting.php on line 3407

Warning: strip_tags() expects parameter 1 to be string, object given in /home1/xxx/public_html/wp-includes/formatting.php on line 3407

Catchable fatal error: Object of class WP_Error could not be converted to string in /home1/xxx/public_html/wp-includes/kses.php on line 1038


Начинаем усиленно гуглить, и понимаем что на русском языке поддержки нет. В этой теме chriscct7 говорит что таки да, это баг в ядре вордпресса и обещает всё исправить к 4.2.3 версии. А если ждать её долго?

Ищем дальше и видим вооот эту тему, опять же где есть два файла патча, да и таск помечен как закрытый.

Всё таки - хочу поднять тему в русскоязычном сообществе. Тот патч - это и есть решение? Есть ли другие варианты всё таки заставить работать режим мультисайтов на вордпрессе? Очень хочется начать использовать этот функционал в вордпрессе на поддоменах.
  • Вопрос задан
  • 1262 просмотра
Решения вопроса 1
CanVas
@CanVas Автор вопроса
Веб-мастер
Сам и отвечу. Послушав Toan Nguyen'a в этом посте, я поставил wordpress-4.0.1-ru_RU. Сразу после установки обновился до 4.2.2. И включил сеть. После добавляю мультисайт, и всё проходит без проблем.

UPD: В такой комбинации не работает весь ajax в консоли управления на основном сайте. на подсайтах всё ок.
Т.е. нельзя создать меню, оперировать пунктами меню и т.д.
выкидывает ошибку в консоли js:

POST site.com/wp-admin/admin-ajax.php 500 (Internal Server Error)

в файле
site.com/wp-admin/load-scripts.php?c=1&load%5B%5D=...,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-draggable,jquery-u&load%5B%5D=i-droppable,wp-ajax-response,jquery-color,wp-lists,postbox,nav-menu&ver=4.2.2
Ответ написан
Комментировать
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы