HSRP с двух сторон туннеля?

Хочу объединить 2 офиса с помощью gre-туннеля между маршрутизаторами cisco. В обоих офисах провайдер дает /30, т.е. мне дается в первом офисе 1.2.3.6 со шлюзом 1.2.3.5, 2.2.3.6 со шлюзом 2.2.3.5 во втором. Я хочу поставить с обеих сторон по 2 циски 881, в которых адрес 1.2.3.6 и 2.2.3.6 резервируется с помощью HSRP. В первом офисе на интерфейсы вешаю адреса: 1.2.3.1, 1.2.3.2, в HSRP говорю 1.2.3.6 — общий. Во втором соответственно: 2.2.3.1, 2.2.3.2, в HSRP 2.2.3.6 — общий. При такой конфигурации кошки инициируют соединение с невалидного для провайдера адреса 1.2.3.1(2.2.3.1) и не видят друг друга, при этом благополучно отвечая на HSRP-шный адрес если запрос идет с любого другого хоста в интернете.

cisco1


interface FastEthernet4

ip address 1.2.3.1 255.255.255.248

standby 20 ip 1.2.3.6


interface Tunnel10

ip unnumbered FastEthernet4

tunnel source 1.2.3.6

tunnel destination 2.2.3.6


interface FastEthernet4

ip address 2.2.3.1 255.255.255.248

standby 20 ip 2.2.3.6


interface Tunnel10

ip unnumbered FastEthernet4

tunnel source 2.2.3.6

tunnel destination 1.2.3.6


Как это можно побороть?
  • Вопрос задан
  • 3547 просмотров
Решения вопроса 1
Anastasia_K
@Anastasia_K Автор вопроса
Ну и сама себе отвечу. Проблема была не в том, что туннель не работал а в том, что внутри него не бегал трафик. все решилось заменой ip unnumbered FastEthernet4 на ip address 192.168.1.1 255.255.255.252 с одной стороны, и ip address 192.168.1.2 255.255.255.252 с другой
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы