@Zohei

Как поставить yii 2.0.1 через composer?

Привет!
Не получается поставить yii2 через composer.
Если прописать "yiisoft/yii2": "*", то ставится все кроме самого фреймворка... если непосредственно указать версию, то ругается на то что пакет не найден....
composer require --prefer-dist "yiisoft/yii2 2.0.1"
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)                                                                   Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - The requested package yiisoft/yii2 1.0.0 could not be found.

Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your minimum-stability setting
   see <https://groups.google.com/d/topic/composer-dev/_g3ASeIFlrc/discussion> for more details.

Read <http://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.

Installation failed, reverting ./composer.json to its original content.

{
    "name": "yiisoft/yii2",
    "description": "Yii PHP Framework Version 2",
    "keywords": ["yii2", "framework"],
    "homepage": "http://www.yiiframework.com/",
    "type": "library",
    "license": "BSD-3-Clause",
    "support": {
        "issues": "https://github.com/yiisoft/yii2/issues?state=open",
        "forum": "http://www.yiiframework.com/forum/",
        "wiki": "http://www.yiiframework.com/wiki/",
        "irc": "irc://irc.freenode.net/yii",
        "source": "https://github.com/yiisoft/yii2"
    },
    "minimum-stability": "stable",
    "require": {
        "php": ">=5.4.0",
        "yiisoft/yii2": "*",
        "yiisoft/yii2-swiftmailer": "*",
        "yiisoft/yii2-redis": "*",
        "yiisoft/yii2-composer": "*",
        "yiisoft/yii2-bootstrap": "@stable",
        "yiisoft/yii2-jui": "@stable",
        "cebe/markdown": "~1.0.0",
        "ezyang/htmlpurifier": "4.6.*",
        "bower-asset/jquery": "@stable",
        "bower-asset/jquery-ui": "@stable",
        "bower-asset/jquery.inputmask": "@stable",
        "bower-asset/typeahead.js": "0.10.*",
        "bower-asset/punycode": "@stable",
        "bower-asset/bootstrap": "@stable",
        "bower-asset/yii2-pjax": "@stable"
    },
    "require-dev": {
        "yiisoft/yii2-debug": "*"
    },
    "config": {
        "process-timeout": 1800
    },
    "extra": {
        "asset-installer-paths": {
            "npm-asset-library": "vendor/npm",
            "bower-asset-library": "vendor/bower"
        }
    }
}


UPD перед тем как писать сюда я конечно же:
1. поставил плагин php composer.phar global require "fxp/composer-asset-plugin:1.0.0-beta4"
на jquery не ругается, он поставился нормально.
2. делал selfupdate. Composer последней версии
Руками скачать фреймворк тоже вариант, но хочется разобраться как работать с новомодным composer который все так восхваляют, а то у меня только одни проблемы с ним пока что)
UPD2 любопытно, что в .lock файле отсутствует yii2.... (при записи "yiisoft/yii2": "*")
  • Вопрос задан
  • 6482 просмотра
Решения вопроса 1
@Zohei Автор вопроса
проблема решилась путем удалением из composer.json этих строк, которые были скопированы с yii2-app-basic и все поставилось!
"name": "yiisoft/yii2",
    "description": "Yii PHP Framework Version 2",
    "keywords": ["yii2", "framework"],
    "homepage": "http://www.yiiframework.com/",
    "type": "library",
    "license": "BSD-3-Clause",
    "support": {
        "issues": "https://github.com/yiisoft/yii2/issues?state=open",
        "forum": "http://www.yiiframework.com/forum/",
        "wiki": "http://www.yiiframework.com/wiki/",
        "irc": "irc://irc.freenode.net/yii",
        "source": "https://github.com/yiisoft/yii2"
    },
    "minimum-stability": "stable",
Ответ написан
Комментировать
Пригласить эксперта
Ответы на вопрос 5
@Nc_Soft
Вот эту фигню надо ставить обязательно
php composer.phar global require "fxp/composer-asset-plugin:1.0.0-beta4"
потом yiisoft/yii2
А вообще я до сих пор не понимаю логику разработчиков, я ставлю PHP фреймворк, а он мне на JQUERY ругается.
Ответ написан
@Yadalay
Php, Mysql, Html, Css, Js/Jquery/Ajax, Laravel
Мне помогли недавно. Может, Вам это поможет - Как установить yii 2 на openserver?
Ответ написан
phpnt
@phpnt
Комментировать
Isolution666
@Isolution666
творческая личность
Здравствуйте.
Composer вам ясно сказал, посмотрите https://groups.google.com/d/topic/composer-dev/_g3... тут надо было в composer.json установить
"minimum-stability": "stable",

И ещё он сказал посмотреть getcomposer.org/doc/articles/troubleshooting.md
для решения дальнейших общих проблем.
Документация у сайта composer на английском, но вы можете перевести через google переводчик.
Ошибка установки, возврат ./composer.json к исходному контенту.
Что-то не правильно установили, или установили один композер по верх другого, никто ж не читает, что в openserver уже есть composer а потом:
Installation failed, reverting ./composer.json to its original content.


Я к тому, что вам пишут подсказки, читайте их, так я решил свои проблемы с composer
Если не понимаете откуда ноги растут, лучше установите Yii2 с нуля, понятное дело что быстрее скопировать и вставить, но понимая свою ошибку, надо сначала вникнуть в то как всё устроено, так я научился устанавливать виджеты с github в ручную )) Так конечно лучше не делать.
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы