kay
@kay

Нужна помощь в кросс-компиляцции драйвера под старое ядро?

Есть драйвер (ath9k_htc), для которого требуется ядро минимум 2.6.24

Есть сорцы ядра 2.6.15 на MIPS девайс с патчами

Нужно собрать драйвер под 2.6.15


Для меня это кажется полнейшим геморроем, т.к. возможно нужно еще интегрировать в старое ядро mac80211, т.к. его в сорцах не наблюдается. Но есть под это ядро уже скомпилированный драйвер из серии ar9170, что дает надежду:

modinfo ./arusb_lnx.ko

filename: ./arusb_lnx.ko

license: GPL

description: Atheros 802.11n Wireless LAN adapter

author: Atheros

alias: usb:v0CF3p1002d*dc*dsc*dp*ic*isc*ip*

alias: usb:v1002p1006d*dc*dsc*dp*ic*isc*ip*

alias: usb:v0846p9010d*dc*dsc*dp*ic*isc*ip*

alias: usb:v2019p5304d*dc*dsc*dp*ic*isc*ip*

alias: usb:v07D1p3C10d*dc*dsc*dp*ic*isc*ip*

alias: usb:v0CF3p9170d*dc*dsc*dp*ic*isc*ip*

depends:

vermagic: 2.6.15-sigma preempt MIPS32_R2 32BIT gcc-4.0


Возможно для гуру всё это не так страшно?
  • Вопрос задан
  • 2693 просмотра
Пригласить эксперта
Ответы на вопрос 1
BuriK666
@BuriK666
Компьютерный псих
Если требует 2.6.24 значит на это есть причины.
Почему бы Вам не обновить свое ядро?
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы