@miha9

Почему Spring не видит html представления?

Здравствуйте. Сгенерировал проект с помощью Spring Boot. Создал представление test.html , которое поместил в папку src/main/resources/static. Создал контроллер, который возвращает имя этого представления, но Spring выдаёт ошибку: Cannot resolve MVC view 'test' .
Посмотрел в интернете: в основном, у всех ошибка из-за того, что указана неверная версия Thymeleaf и люди рекомендуют вовсе отказаться от указания версии Thymeleaf, дав родительскому узлу Spring Boot самому решить, какую версию использовать.
Однако, мне кажется, что таймлиф тут непричем, потому что я работаю со статическими представлениями и теперь.
Проблемы спустя сутки так и не решил...
Извиняюсь, если неправильно использовал некоторые термины (только учусь). Буду благодарен, если поправите.

Контроллер:
package com.example.learningproject2.controllers;

import org.springframework.stereotype.Controller;
import org.springframework.web.bind.annotation.RequestMapping;

@Controller
public class MainController {

    @RequestMapping("/test")
    public String test(){
        return "test";
    }
}


pom.xml (таймлиф не добавлял):

<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
         xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 https://maven.apache.org/xsd/maven-4.0.0.xsd">
    <modelVersion>4.0.0</modelVersion>
    <parent>
        <groupId>org.springframework.boot</groupId>
        <artifactId>spring-boot-starter-parent</artifactId>
        <version>3.2.5</version>
        <relativePath/> <!-- lookup parent from repository -->
    </parent>
    <groupId>com.example</groupId>
    <artifactId>learningProject2</artifactId>
    <version>0.0.1-SNAPSHOT</version>
    <name>learningProject2</name>
    <description>learningProject2</description>
    <properties>
        <java.version>22</java.version>
    </properties>
    <dependencies>
        <dependency>
            <groupId>org.springframework.boot</groupId>
            <artifactId>spring-boot-starter-web</artifactId>
        </dependency>

        <dependency>
            <groupId>org.springframework.boot</groupId>
            <artifactId>spring-boot-starter-test</artifactId>
            <scope>test</scope>
        </dependency>
    </dependencies>

    <build>
        <plugins>
            <plugin>
                <groupId>org.springframework.boot</groupId>
                <artifactId>spring-boot-maven-plugin</artifactId>
            </plugin>
        </plugins>
    </build>

</project>


Структура проекта:
6633833118f3c637609569.png
  • Вопрос задан
  • 160 просмотров
Решения вопроса 1
xez
@xez Куратор тега Java
TL Junior Roo
0. Используйте java LTS версию
1. Spring не знает где ваши вью находятся. Либо подключите таймлиф, либо добавьте конфигов.
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы
Bell Integrator Ульяновск
До 400 000 ₽
Bell Integrator Ижевск
До 400 000 ₽
Bell Integrator Хабаровск
До 400 000 ₽