@ginap0

Gulp require() of es modules is not supported что делать?

Вот код package.json:
{
  "type": "commonjs",
  "name": "ExampleApp",
  "version": "1.0.0",
  "description": "",
  "main": "index.js",
  "scripts": {
    "test": "echo \"Error: no test specified\" && exit 1"
  },
  "author": "",
  "license": "ISC",
  "devDependencies": {
    "gulp": "^4.0.2",
    "gulp-autoprefixer": "^9.0.0",
    "gulp-rename": "^2.0.0",
    "gulp-sass": "^5.1.0",
    "sass": "^1.71.1"
  }
}


Вот код gulpfile:
var gulp = require('gulp');
var rename = require('gulp-rename');
const sass = require('gulp-sass')(require('sass'));
var autoprefixer = require('gulp-autoprefixer');

function css_style(done) {

gulp.src('./sass/style.sass')
.pipe( sass({
errorLogToConsole: true,
outputStyle: 'compressed'
}) )
.on( 'error', console.error.bind(console) )

.pipe(autoprefixer({
browsers: ['last 2 versions'],
cascade: false
}))

.pipe(rename({suffix: '.min'}))
.pipe(gulp.dest('./css/'));

done();
}

gulp.task(css_style);
  • Вопрос задан
  • 40 просмотров
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы