alekaberdichev
@alekaberdichev
Инженер

Как автоматически подставлять шлюз провайдера в маршрут при резервировани каналов?

Сделал авто переключения между провайдерами по данной статье https://xn----7sba7aachdbqfnhtigrl.xn--j1amh/nastr...

Там есть статья где указано как настроить скрипт в dhcp client где должен автоматически узнавать шлюз провайдера и подставлять его в созданный маршрут в route. 

Но скрипт почему-то не действует. Может кто-то проверить или правильно написан скрипт 

{
:local rmark "ISP1"
:local count [/ip route print count-only where comment="ISP1"]
:If ($bound=1) do={
:If ($count = 0) do={
/ip route add gateway=gateway-address comment="ISP1" distance=1
/ip route add gateway=gateway-address comment="Netwach" distance=1 dst-address=8.8.4.4
} else={
:If ($count = 1) do={
:local test [/ip route find where comment="ISP1"]
:if [(/ip route get $test gateway] !=gateway-address) do={
/ip route set $test gateway=gateway-address
}
} else={
:error "Multiple routes found"
}
}
} else={
/ip route remove (find comment="ISP1"]
/ip route remove (find comment="Netwatch"]
}


Прошу строго не судить, так как скрипты никогда не писал.
  • Вопрос задан
  • 170 просмотров
Пригласить эксперта
Ответы на вопрос 1
b1ora
@b1ora
Настройка Микротик РФ
Получить шлюз скриптом попробуй взять за основу
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы