Viji
@Viji
Associate DevOps Engineer

Можно ли заставить Node 18 использовать скомпилированную версию библиотеки?

Имею Ubuntu 18, на ней node 18+ пишет ошибку

node -v
/lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.28' not found (required by node)


Скомпилил версию libc 2.28 - можно ли как-то заставить node ее использовать, не трогая ту, которая в операционке:
/lib/x86_64-linux-gnu/libc.so.6
  • Вопрос задан
  • 168 просмотров
Пригласить эксперта
Ответы на вопрос 1
MvcBox
@MvcBox
Software Developer [C/C++/JS(for Node.js)/etc]
При запуске ноды в переменной окружения LD_LIBRARY_PATH можете задать свои пути поиска библиотек.
LD_LIBRARY_PATH="тут_ваши_пути_поиска" node ./index.js
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы