des1roer
@des1roer
ученье - свет, а неученье - приятный полумрак

PHP почему Sockets extension is not enabled?

composer.json

"require": {
        "php": "~7.4",
        "ext-json": "*",
        "yidas/yii2-composer-bower-skip": "~2.0.5",
        "yiisoft/yii2": "~2",
        "ext-zip": "*",
        "yiisoft/yii2-queue": "^2.3",
        "enqueue/amqp-lib": "^0.10.9"
    },

Ошибка
www@ef0d8432969f:/var/www/service$ ./yii queue/listen -v

PHP Warning:
Sockets extension is not enabled in
/var/www/service/vendor/php-amqplib/php-amqplib/PhpAmqpLib/Helper/SocketConstants.php
on line 34

В докер файл есть

RUN docker-php-ext-install sockets


Использовал доку https://www.yiiframework.com/extension/yiisoft/yii...

LHbNx.png
  • Вопрос задан
  • 65 просмотров
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы