Как отсортировать Excel столбики?

Имеются поля "Дата" и "Время", по ним нужно отсортировать таблицу.
Вид Excel
62eabd8f5f415239286548.png
Что нужно получить
62eabda07b8b5439128046.png

Для этого создал дополнительные поля: Год, Месяц, День и Время.
Поле "Дата" имеет формат дата: 14.03.2002
Поля "Время" имеют формат время: 13:30
Поле "Год" имеет формулу: =ЕСЛИ(B2="";2999;ГОД(B2))
Поле "Месяц" имеет формулу: =МЕСЯЦ(B2)
Поле "День" имеет формулу: =ДЕНЬ(B2)
Последний столбик "Время" имеет формулу: =ЕСЛИ(C2="";"23:00";C2)

Сортирую по 4-м полям и нечего не сортирует, если взять только столбик "Год" сортирует, по "Год" и "Месяц" уже не сортирует.

Как решить проблему?
Доп.вопрос: Как сделать кнопку, чтобы при клике сортировалась автоматом, чтобы каждый раз руками не выбирать поля для сортировки.

Файл excel: https://disk.yandex.ru/i/HFOF1tUBM1bFpg
  • Вопрос задан
  • 41 просмотр
Решения вопроса 1
tsklab
@tsklab
Здесь отвечаю на вопросы.
Формат ячеек: Дата (для второго столбца).
Работает
62eac39ba36cd943597084.png


Как сделать кнопку, чтобы при клике сортировалась автоматом, чтобы каждый раз руками не выбирать поля для сортировки?

Одна кнопка
62eb4c9118fbf138082819.png
Настройки сохраняются. Выделяется автоматически.
Ответ написан
Комментировать
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы