arsenqaaa
@arsenqaaa

Лог действия другого пользователя микротик?

Добрый день. Я создал пользователя второго на микротике и хочу видеть всю его активность. Какие он настройки менял и тд. Можете пожалуйста подсказать как это правильно сделать.
  • Вопрос задан
  • 364 просмотра
Пригласить эксперта
Ответы на вопрос 4
@TheBigBear
СтарОдмины мы
Сохраните эталонную конфигурацию
Поставьте скрипт, отправляющий раз в сутки например, на почту копию текущей конфигурации
Всегда сравнить можно с эталонной - редакторов умеющих сравнивать два текстовых файла полно
Ответ написан
Комментировать
@1rV1N
Подними где нибудь syslog server и отправляй логи с микрота на него
/system logging action set 3 remote=syslog_IP remote-port=554
/system logging add action=remote topics=info
/system logging add action=remote topics=critical
/system logging add action=remote topics=error
/system logging add action=remote topics=warning
Ответ написан
Комментировать
@5exi
https://www.ekzorchik.ru/2019/03/backing-up-mikrot...
Если коротко то git тебе в помощь. Заодно и конфиги бэкапить сможешь и вернуться на любой момент времени.
Ответ написан
Комментировать
Maxlinus
@Maxlinus
можно чтобы в Телеграм отправлялось через бота

скрипт для микротика
:global lastTime
:global output
:global mtIdentity [/system identity get name];
:global botID "bot5042278208:AAHe-YpKuChjreeb54nbnssssss" ;
:global myChatID "7890000000" ;

:local LogGet [ :toarray [ /log find topics~"infol" || message~"by admin" ] ] ;
:local LogtLineCount [ :len $LogGet ] ;
if ($LogtLineCount > 0) do={
   :local currentTime "$[ /log get [ :pick $LogGet ($LogtLineCount -1) ] time ]";
   :if ([:len $currentTime] = 10 ) do={
      :set currentTime [ :pick $currentTime 0 10 ];
   }
   :set output "$currentTime - $[/log get [ :pick $LogGet ($LogtLineCount-1) ] message ]";
   :if (([:len $lastTime] < 1) || (([:len $lastTime] > 0) && ($lastTime != $currentTime))) do={
      :set lastTime $currentTime ;
         :tool fetch url=("https://api.telegram.org/$botID/sendmessage\?chat_id=$myChatID&text=\"$mtIdentity\" :  $output") keep-result=no
   }
}


измените поля :
:global botID "идентификатор бота" ;
:global myChatID "идентификатор юзера" ;
в этой строке:
:local LogGet [ :toarray [ /log find topics~"infol" || message~"by admin" ] ] ;
можно добавлять еще нужные данные для отправки

в телеграмм будет выглядеть так
62cbfd17a231c595098802.jpeg
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы