UglukFearless
@UglukFearless
Веб-разработчик

Как решить проблему установкисвоего пакета Packagist пакета через Composer?

Я не являюсь php разработчиком (не основной профиль), а потому испытваю трудности с некоторыми инструментами. Возникла проблема с установкой вновь созданного пакета через composer.
1. Я создал репозиторий на GitHub:
https://github.com/aurigma/cchub-magento-integration
2. Установил ему тег версии
3. Разместил его на packagist:
https://packagist.org/packages/aurigma/php-asset-p...

Пакет не отображает проблем, однако, мне никак не удаётся установить его через composer, я получаю ошибку типа:
Could not find a version of package aurigma/magento-customers-canvas matching your minimum-stability (dev). Require it with an explicit version constraint allowing its desired stability.

Это происходит при любом значении "minimum-stability".

На данный момент я в тупике и очень надеюсь на помощь кого-то, кто хорошо понимает процесс публикации на packagist.

p.S. пока я пытался поправить проблему совершил много манипуляций с тегами, удалением версии из composer.json и тд.
  • Вопрос задан
  • 36 просмотров
Решения вопроса 1
UglukFearless
@UglukFearless Автор вопроса
Веб-разработчик
Собака оказалась зарыта нестандартным образом и это связано с совокупностью нескольких факторов, а именно:
  1. У меня был даунгрейднутый composer до 1 версии (это связано с тем, что, когда я начинал разработку Magento ещё не поддерживала Composer 2... И нет, это было не при царе Саламоне, а всего несколько месяцев назад)
  2. Пакеты, которые я пытался создать и выложить были добавлены только что, что привело к тому, что они недоступны из под Composer 1


Выглядит это следующим образом: Composer 1 осведомлён о существовании пакета, может его найти, получить в списке, пакет есть на сервере (тут апи общее). Однако, для получения подробной информации о пакете нужно использовать зависящее от версии апи. Для только что созданных пакетов запрос по старому апи возвращает 404... Поэтому composer не только не мог найти никакой версии, но и до конца не мог понять, существует у него пакет или нет.

Решил проблему вернувшись на вторую версию Composer.
Ответ написан
Комментировать
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы