@CodeOrNotCode

Как поставить нужную версию Python на VS code(если Vs code эту версию не видит)?

На днях перешел с Ubuntu на Linux Manjaro и установил VS code поставл все плагины связанные с Python
и начал выбирать интерпретатор (версии 3.10). Я знаю что он установлен на пк6286984e7c9a5494996812.png и во что я вижу на VS Code 6286987a2d107144152757.png
Версии 3.10 как не бывало... (Если что я пытался прописать все пути которые были возможны)
Мне кажется VS Code видит python 3.10 как 3.9, но это не так потому, что все модули приходиться устанавливать для каждой версии отдельно и такжетерминал VS Code не видит господнюю команду sudo... при вызове её выдаёт ошибку: "sh: sudo: команда не найдена"
  • Вопрос задан
  • 87 просмотров
Пригласить эксперта
Ответы на вопрос 1
Самый простой вариант - взять нормальный менеджер окружений (и пакетов заодно), например Poetry, ну или pipenv, если очень хочется, развернуть где-нибудь в подпапке .venv вирт. окружение для вашего проекта, и натравить на него VS Code (вероятно, он сам даже предложит вам в списке этот вариант). Это если вы собираетесь делать что-то сложнее Hello world.

Ну а вообще почему бы вам не ввести путь /usr/bin/python3.10? Ну мало ли почему vscode его не нашёл.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы