@domanskiy

Как заставить PyCharm видеть Python 3.10 установленный в системе Debian 11?

Стоит Debian 11.
Установлен Python 3.10.1.
В системе через терминал видны 3.9 и 3.10.1 версии, т.е. python3.10 --version выдаёт ответ Python 3.10.1.

Установил Pycharm.
Пробовал через apt install.
Сегодня через установку через загрузку .tar.gz и т.д. Всё стандартно.
Pycharm упорно не видит пайтон 3.10 при установке среды.
Если выбрать System Interpreter, видит python3 и python3.9.
В обоих случаях это 3.9.

Что делать? Мне для проекта нужен именно 3.10.
  • Вопрос задан
  • 614 просмотров
Решения вопроса 1
karabanov
@karabanov
Системный администратор
Не надо устанавливать интерпретатор в систему через штатный менеджер пакетов или из исходников.
Используй pyenv (не забудь установить библиотеки).

Чтобы установить pyenv curl https://pyenv.run | bash и следуй инструкциям.
Установить Python pyenv install 3.10.1
Создай virualenv и работай в нём, чтобы не сломать систему.
Ответ написан
Пригласить эксперта
Ответы на вопрос 1
@deniz1983
...
Pycharm упорно не видит пайтон 3.10 при установке среды.
А как проверяли? Создавая новый проект, если из выпадающего списка, который Base interpreter не видно нужной версии, то там правее кликаем на "..." и в папках ищем нужную версию Python.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы