@Nirealto

Mikrotik: l2tp client -> только для устройств с определённых IP. Как?

Здравствуйте! Пытаюсь освоить настройку MikroTik hAP ac lite, задача следующая:

Одно из устройств, допустим с IP адресом 192.168.88.250 нужно пускать в интернет только через VPN l2tp-out1, а всё остальные устройства оставить подключёнными напрямую. Желательно иметь возможно добавлять несколько IP адресов.

Сейчас в настройках l2tp-out1 стоит:
Add Default Route yes
Default Route Distance 1

Для DHCP Client:
Add Default Route yes
Default Route Distance 100

И приходится вручную включать-отключать l2tp-out1, но с такими настройками все подключённые устройства работают через VPN, что не совсем удобно, да и хотелось бы автоматизировать этот момент.

Настроить L2TP/IPsec Client по инструкциям в сети смог, а вот дальше понимания не хватает.
  • Вопрос задан
  • 71 просмотр
Пригласить эксперта
Ответы на вопрос 3
@Drno
Роут для впн выставите больше 2х...
Остальное - маркировка трафф
Маркируем, в мангл, потом в роуте задаем куда

Погунлите - микротик, обход блокировок. Принцип тот же
Ответ написан
Комментировать
@dronmaxman
VoIP Administrator
создаем адресный лист
/ip firewall address-list add address=192.168.88.200 list=VPN-USERS

создаёте дефолт маршруты с маркировками для VPN, gateway указан для примера, можно привязать в интерфейсу LT2P
/ip route add dst-address=0.0.0.0/0 gateway=3.3.3.3 routing-mark=VPN

на входе через mangle вешаете routing-mark по нужному src-address
/ip firewall mangle add chain=prerouting src-address-list=VPN-USERS action=mark-routing new-routing-mark=VPN

на выходе в nat делаете src-nat/masquerade по маркировке
/ip firewall nat add chain=src-nat action=masquerade routing-mark=VPN
Ответ написан
Комментировать
karabanov
@karabanov
Системный администратор
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы