@victor_skoblin

Из-за чего l2tp на mikrotik медленно работает?

Добрый день! Имеется два роутера mikrotik: hEx и hap ac2, стоят в разных домах с разными провайдерами. Между ними построен l2tp-туннель с ipsec с включённым BCP (для dlna). Соответственно, имеется l2 связность сетей. В сети hex стоит nas, в сети ac2 стоит клиент. Я скачиваю файл с nas на клиента - скорость не превышает 500 килобайт в секунду. Если загружать файл с клиента на nas, то утилизируется весь канал между роутерами (около 100 мбит/с). Почему-то именно на l2tp присутствует такая ассиметрия. Если заменить тоннель на pptp, то скорости отдачи и загрузки примерно сравниваются, хоть и меньше скорости по тарифам. Куда в этом деле копать?

Профили vpn на обоих роутерах:
add bridge=HOME bridge-learning=no name=HOME_bridging use-encryption=yes


Конфиг l2tp-сервера:
/interface l2tp-server server
set authentication=mschap2 default-profile=VPN-Private enabled=yes \
ipsec-secret=*** use-ipsec=yes
  • Вопрос задан
  • 218 просмотров
Пригласить эксперта
Ответы на вопрос 2
Предложил бы свериться с этой таблицей https://wiki.mikrotik.com/wiki/Manual:IP/IPsec#Har...
В частности проверить, что настройки шифрования установлены таким образом, чтобы оба устройства могли использовать аппаратное ускорение для криптографических операций.

Проверить что не фрагментируются пакеты - установить mtu меньше для l2tp, ipsec
Ответ написан
@korsar182
MTU для L2TP туннеля установите 1390.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы