small_jedi
@small_jedi

Что делать, если docker при установке выдает ошибку что нет пакета zlib?

Всем привет. Срочная проблема, помогите кто шарит. Пытаемся поставить на debian8 удалившийся пакет докера, но получаем след. ошибку
ERROR: failed to register layer: Error processing tar file(exit status 1: /usr/bin/unpigz: /usr/local/lib/libz.so.1: version `ZLIB_1.2.5.1' not found (required by /usr/bin/unpigz)
):

Как можно поставить либу zlib данной версии?
  • Вопрос задан
  • 212 просмотров
Пригласить эксперта
Ответы на вопрос 1
@Drno
архиватор переставьте, он по идее должен потянуть за собой нужное...
sudo apt update
sudo apt install unzip

Судя по гуглу, для докера...

sudo apt-get install zlib1g
apt-get install zlib1g-dev
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы