• Что произойдёт если в js объявить переменную без слова var, const или let?

    fapchat
    @fapchat Автор вопроса
    не корректно - так корректно.
    Пусть ваш ответ станет решением
    Написано
  • Почему не работает sublimeLinter в Sublime?

    fapchat
    @fapchat
    а у меня всё-равно не работает!!!
    Написано
  • Что в phpstorm и c xdebug я делаю не так?

    fapchat
    @fapchat Автор вопроса
    DevMan, поставил, теперь по неофициальным гайдам пытаюсь поставить xdebug для chrome, но ничего не работает
    Написано
  • Почему версии php в phpinfo() и php -i расходятся?

    fapchat
    @fapchat Автор вопроса
    nokimaro, уже всё это исправил
    Написано
  • Почему в туториале к xdebug'u просят использовать команду automake и как исправить ошибку?

    fapchat
    @fapchat Автор вопроса
    Дмитрий, на официальном сайте xdebug описаны эти шаги
    Написано
  • Почему версии php в phpinfo() и php -i расходятся?

    fapchat
    @fapchat Автор вопроса
    и поставить нужную версию в apache не получается
    sudo a2enmod php7.4
    ERROR: Module php7.4 does not exist!
    Написано
  • Почему версии php в phpinfo() и php -i расходятся?

    fapchat
    @fapchat Автор вопроса
    Кстати ни одну из старых версий у меня не поучилось удалить
    fapchat@fapchat-Lenovo-G570:~$ sudo apt-get remove --purge php5*
    Чтение списков пакетов… Готово
    Построение дерева зависимостей
    Чтение информации о состоянии… Готово
    Заметьте, выбирается «php5.6-tokenizer» для шаблона «php5*»
    Заметьте, выбирается «php5-mapscript» для шаблона «php5*»
    Заметьте, выбирается «php5.6-gnupg» для шаблона «php5*»
    Заметьте, выбирается «php5.6-posix» для шаблона «php5*»
    Заметьте, выбирается «php5.6-iconv» для шаблона «php5*»
    Заметьте, выбирается «php5-xsl» для шаблона «php5*»
    Заметьте, выбирается «php5.6-http» для шаблона «php5*»
    Заметьте, выбирается «php5.6-mysqlnd» для шаблона «php5*»
    Заметьте, выбирается «php5.6-interbase» для шаблона «php5*»
    Заметьте, выбирается «php5.6-pdo» для шаблона «php5*»
    Заметьте, выбирается «php5.6-pdo-mysql» для шаблона «php5*»
    Заметьте, выбирается «php5.6-rrd» для шаблона «php5*»
    Заметьте, выбирается «php5.6-xmlreader» для шаблона «php5*»
    Заметьте, выбирается «php5.6-xmlrpc» для шаблона «php5*»
    Заметьте, выбирается «php5.6-uploadprogress» для шаблона «php5*»
    Заметьте, выбирается «php5.6-xcache» для шаблона «php5*»

    ...

    fapchat@fapchat-Lenovo-G570:~$ ls -la /etc/php/
    итого 40
    drwxr-xr-x 8 root root 4096 янв 18 15:12 .
    drwxr-xr-x 141 root root 12288 апр 3 19:21 ..
    drwxr-xr-x 3 root root 4096 янв 18 15:12 5.6
    drwxr-xr-x 4 root root 4096 мар 30 03:00 7.0
    drwxr-xr-x 3 root root 4096 янв 18 15:12 7.1
    drwxr-xr-x 3 root root 4096 янв 18 15:12 7.2
    drwxr-xr-x 7 root root 4096 окт 23 21:45 7.3
    drwxr-xr-x 5 root root 4096 дек 31 15:30 7.4
    ls -la /etc/php/ всё равно показывает 5.6
    Но с другой стороны это не необходимо( удалять старые версии)
    Написано
  • Почему версии php в phpinfo() и php -i расходятся?

    fapchat
    @fapchat Автор вопроса
    с xdebug точно могут быть проблемы, тк там даже установка зависит от вывода php -i
    Написано
  • Как установить Libevent для php?

    fapchat
    @fapchat Автор вопроса
    на самом деле оно мне, возможно, не нужно, ведь на странице документации php написано
    Это расширение требует библиотеки » libgearman, » libevent и » uuid и запущенного Gearman сервера.
    (это про gearman)
    Но
    <?php
    
    echo 'GEARMAN VER: '.print gearman_version().PHP_EOL;

    выдаёт вот такой результат
    1.1.18+ds GEARMAN VER: 1
    То есть у меня всё работает)
    Написано
  • Как установить Libevent для php?

    fapchat
    @fapchat Автор вопроса

    fapchat@fapchat-Lenovo-G570:~/Загрузки/uuid-1.6.2/pecl-event-libevent$ make && sudo make install

    Build complete.
    Don't forget to run 'make test'.

    Installing shared extensions: /usr/lib/php/20190902/

    ...
    fapchat@fapchat-Lenovo-G570:~/Загрузки/uuid-1.6.2/pecl-event-libevent$ make test
    ...
    PHP : /usr/bin/php7.4
    Warning: PHP Startup: libevent: Unable to initialize module
    Module compiled with module API=20151012
    PHP compiled with module API=20190902
    These options need to match
    in Unknown on line 0

    Deprecated: Directive 'track_errors' is deprecated in Unknown on line 0
    ...

    SKIP pecl/libevent - general [tests/libevent001.phpt] reason: pecl/libevent needed
    SKIP pecl/libevent - bug https://github.com/expressif/pecl-event-libevent/i... [tests/libevent002.phpt] reason: pecl/libevent needed
    SKIP pecl/libevent - bug https://github.com/expressif/pecl-event-libevent/i... [tests/libevent003.phpt] reason: pecl/libevent needed
    SKIP pecl/libevent - bug https://github.com/expressif/pecl-event-libevent/i... [tests/libevent004.phpt] reason: pecl/libevent needed
    SKIP pecl/libevent - bug https://github.com/expressif/pecl-event-libevent/i... [tests/libevent005.phpt] reason: pecl/libevent needed
    SKIP pecl/libevent - bug https://github.com/expressif/pecl-event-libevent/i... [tests/libevent006.phpt] reason: pecl/libevent needed
    SKIP pecl/libevent - bug https://github.com/expressif/pecl-event-libevent/i... [tests/libevent007.phpt] reason: pecl/libevent needed
    SKIP pecl/libevent - bug https://github.com/expressif/pecl-event-libevent/i... [tests/libevent008.phpt] reason: pecl/libevent needed
    PHP Deprecated: The each() function is deprecated. This message will be suppressed on further calls in /home/fapchat/Загрузки/uuid-1.6.2/pecl-event-libevent/run-tests.php on line 2446

    ...

    Number of tests : 8 0
    Tests skipped : 8 (100.0%) --------


    Они пишут
    pecl/libevent needed
    Но разве я ни его устанавливаю?
    Написано
  • Почемушрифт превращавется в каракули когда я навожу на что-либо курсор?

    fapchat
    @fapchat Автор вопроса
    да, железо как вариант вполне годится, ведь по кд ноутбук горячий, вряд ли удастся как-то исправить, не хочу даже говорить почему, но раньше такого даже с перегретым железом не было.
    Изначально такие шрифты в убунту работали нормально, драйвера я самостоятельно точно не устанавливал, но постоянно предлагаются какие-либо обновления, может быть там и драйвера как-то обновились и дело пошло...
    Написано
  • Kак собрать PHP с опцией --with-curl[=DIR] на ubuntu?

    fapchat
    @fapchat Автор вопроса
    Дмитрий, ваш у меня не сработал, какая-то ошибка
    Написано
  • Kак собрать PHP с опцией --with-curl[=DIR] на ubuntu?

    fapchat
    @fapchat Автор вопроса
    Александр Аксентьев, Загрузить - значит скачать? И где ставить этот FOLLOW REDIRECTS?(вот здесь)
    <?php  
    curl_setopt($curl, CURLOPT_POSTFIELDS, "foo");
    curl_setopt($curl, CURLOPT_FOLLOWLOCATION, true);
    curl_setopt($curl, CURLOPT_CUSTOMREQUEST, "POST");
    Написано
  • Kак собрать PHP с опцией --with-curl[=DIR] на ubuntu?

    fapchat
    @fapchat Автор вопроса
    Сослан Хлоев, автор ответа забыл - я исправил
    Написано
  • Как с помощью location перенаравить пользователя на страницу сайта?

    fapchat
    @fapchat Автор вопроса
    К сожалению, страница, которую вы искали в этом блоге, не существует.
    5e21e1c1ad1d4058032179.pngВот это
    для поиска информации
    ?
    Написано
  • Kак собрать PHP с опцией --with-curl[=DIR] на ubuntu?

    fapchat
    @fapchat Автор вопроса
    fapchat@fapchat-Lenovo-G570:~$
    apt get install php7.3-curl
    E: Неверная операция get
    fapchat@fapchat-Lenovo-G570:~$ sudo apt-get install php7.3-curl
    Чтение списков пакетов… Готово
    Построение дерева зависимостей
    Чтение информации о состоянии… Готово
    Уже установлен пакет php7.3-curl самой новой версии (7.3.13-1+ubuntu18.04.1+deb.sury.org+1).
    Следующие пакеты устанавливались автоматически и больше не требуются:
    liblockfile-bin liblockfile1 linux-headers-5.0.0-36
    linux-headers-5.0.0-36-generic linux-image-5.0.0-36-generic
    linux-modules-5.0.0-36-generic linux-modules-extra-5.0.0-36-generic
    php7.3-dev php7.3-xmlrpc pigz
    Для их удаления используйте «sudo apt autoremove».
    Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 35 пакетов не обновлено.
    Написано
  • Как с помощью location перенаравить пользователя на страницу сайта?

    fapchat
    @fapchat Автор вопроса
    Шохрух Шаймардонов, я не спорю, но я много гуглю перед тем как задавать вопросы
    Написано
  • Kак собрать PHP с опцией --with-curl[=DIR] на ubuntu?

    fapchat
    @fapchat Автор вопроса
    Сослан Хлоев, что-то типа этого было
    fapchat@fapchat-Lenovo-G570:~$ sudo apt-get install libcurl4-openssl-dev
    Чтение списков пакетов… Готово
    Построение дерева зависимостей
    Чтение информации о состоянии… Готово
    Уже установлен пакет libcurl4-openssl-dev самой новой версии (7.58.0-2ubuntu3.8pop1).
    Следующие пакеты устанавливались автоматически и больше не требуются:
    libcurl3-nss liblockfile-bin liblockfile1 linux-headers-5.0.0-36
    linux-headers-5.0.0-36-generic linux-image-5.0.0-36-generic
    linux-modules-5.0.0-36-generic linux-modules-extra-5.0.0-36-generic
    php7.3-dev php7.3-xmlrpc pigz
    Для их удаления используйте «sudo apt autoremove».
    Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 35 пакетов не обновлено.

    А когда я решил установить что-то похожее, старое удалилось
    fapchat@fapchat-Lenovo-G570:~$ sudo apt-get install libcurl4-nss-dev
    Чтение списков пакетов… Готово
    Построение дерева зависимостей
    Чтение информации о состоянии… Готово
    Следующие пакеты устанавливались автоматически и больше не требуются:
    liblockfile-bin liblockfile1 linux-headers-5.0.0-36
    linux-headers-5.0.0-36-generic linux-image-5.0.0-36-generic
    linux-modules-5.0.0-36-generic linux-modules-extra-5.0.0-36-generic
    php7.3-dev php7.3-xmlrpc pigz
    Для их удаления используйте «sudo apt autoremove».
    Предлагаемые пакеты:
    libcurl4-doc libidn11-dev libkrb5-dev libldap2-dev libnss3-dev librtmp-dev
    libssh2-1-dev pkg-config zlib1g-dev
    Следующие пакеты будут УДАЛЕНЫ:
    libcurl4-openssl-dev
    Следующие НОВЫЕ пакеты будут установлены:
    libcurl4-nss-dev
    Обновлено 0 пакетов, установлено 1 новых пакетов, для удаления отмечено 1 пакетов, и 35 пакетов не обновлено.
    Необходимо скачать 396 kB архивов.
    После данной операции объём занятого дискового пространства возрастёт на 12,3 kB.
    Хотите продолжить? [Д/н] y
    Пол:1 ppa.launchpad.net/system76/pop/ubuntu bionic/main amd64 libcurl4-nss-dev amd64 7.58.0-2ubuntu3.8pop1 [396 kB]
    Получено 396 kB за 1с (655 kB/s)
    (Чтение базы данных … на данный момент установлено 277675 файлов и каталогов.)
    Удаляется libcurl4-openssl-dev:amd64 (7.58.0-2ubuntu3.8pop1) …
    Выбор ранее не выбранного пакета libcurl4-nss-dev:amd64.
    (Чтение базы данных … на данный момент установлено 277656 файлов и каталогов.)
    Подготовка к распаковке …/libcurl4-nss-dev_7.58.0-2ubuntu3.8pop1_amd64.deb …
    Распаковывается libcurl4-nss-dev:amd64 (7.58.0-2ubuntu3.8pop1) …
    Настраивается пакет libcurl4-nss-dev:amd64 (7.58.0-2ubuntu3.8pop1) …
    Обрабатываются триггеры для man-db (2.8.3-2ubuntu0.1) …
    Написано
  • Как с помощью location перенаравить пользователя на страницу сайта?

    fapchat
    @fapchat Автор вопроса
    никаких изменений
    document.querySelector("input").onclick = function() {
        let result = confirm("Do you want to log out?");
        if (result) {
    window.location.reload("127.0.0.1/qwert-master");
            alert(":-<"); //alert необходим
    
    }
     }
     console.log(document.querySelector("input"));
    console.log(document.querySelector("input").onclick);
    Написано