• Смена паролей, или удаления локальных учетных записей в АД?

    djalin
    @djalin Автор вопроса
    Можно ссылку на такой скрипт?
  • Как применить групповую политику один раз?

    djalin
    @djalin Автор вопроса
    Alexey Dmitriev, Да вроде оно, буду пробовать, спасибо.
  • Как применить групповую политику один раз?

    djalin
    @djalin Автор вопроса
    Sasha Odarchuk, скрипт который ставит софт, софт нужен только один раз - для проведения инвентаризации, ну и еще по мелочах. (копирует папку на пк)

    Можете ткнуть пальцем в галочку? Иногда могу просто пропустить очевидное - глаз уже замылен.
  • Почему падает logstash?

    djalin
    @djalin Автор вопроса
    Saboteur, да поднят, сейчас на всякий пожарный переустанвлю с нуля - может что уже и напортачил
  • Почему падает logstash?

    djalin
    @djalin Автор вопроса
    добавил конфиг
    input {
      udp {
        port => 5145
        type => mikrot
      }
    }
    
    output {
      if [type] == "mikrot" {
        elasticsearch {
          hosts => "elasticsearch:9200"
          index => "logstash-mikrot-%{+YYYY.MM.dd}"
        }
        # stdout { codec => rubydebug }
      }
    }


    Теперь ошибка доругая

    [2020-07-01T10:32:09,872][WARN ][logstash.outputs.elasticsearch] Attempted to resurrect connection to dead ES instance, but got an error. {:url=>"http://elasticsearch:9200/", :error_type=>LogStash::Outputs::ElasticSearch::HttpClient::Pool::HostUnreachableError, :error=>"Elasticsearch Unreachable: [http://elasticsearch:9200/][Manticore::ResolutionFailure] elasticsearch: Name or service not known"}
  • Почему падает logstash?

    djalin
    @djalin Автор вопроса
    Saboteur, нужно принять логи с микротика и передать в еластик серч, есть такой конфиг

    # Sample Logstash configuration for creating a simple
    # Beats -> Logstash -> Elasticsearch pipeline.
    
    input {
      beats {
        port => 5044
      }
    }
    
    output {
      elasticsearch {
        hosts => ["http://localhost:9200"]
        index => "%{[@metadata][beat]}-%{[@metadata][version]}-%{+YYYY.MM.dd}"
        #user => "elastic"
        #password => "changeme"
      }
    }
  • Почему падает logstash?

    djalin
    @djalin Автор вопроса
    директория conf.d - пустая, есть еще файл logstash-sample.conf

    # Sample Logstash configuration for creating a simple
    # Beats -> Logstash -> Elasticsearch pipeline.
    
    input {
      beats {
        port => 5044
      }
    }
    
    output {
      elasticsearch {
        hosts => ["http://localhost:9200"]
        index => "%{[@metadata][beat]}-%{[@metadata][version]}-%{+YYYY.MM.dd}"
        #user => "elastic"
        #password => "changeme"
      }
    }


    еще есть pipelines.yml
    # This file is where you define your pipelines. You can define multiple.
    # For more information on multiple pipelines, see the documentation:
    #   https://www.elastic.co/guide/en/logstash/current/multiple-pipelines.html
    
    - pipeline.id: main
      path.config: "/etc/logstash/conf.d/*.conf"
  • Почему падает logstash?

    djalin
    @djalin Автор вопроса
    Андрей Николаев,
    # Settings file in YAML
    #
    # Settings can be specified either in hierarchical form, e.g.:
    #
    #   pipeline:
    #     batch:
    #       size: 125
    #       delay: 5
    #
    # Or as flat keys:
    #
    #   pipeline.batch.size: 125
    #   pipeline.batch.delay: 5
    #
    # ------------  Node identity ------------
    #
    # Use a descriptive name for the node:
    #
    # node.name: test
    #
    # If omitted the node name will default to the machine's host name
    #
    # ------------ Data path ------------------
    #
    # Which directory should be used by logstash and its plugins
    # for any persistent needs. Defaults to LOGSTASH_HOME/data
    #
    path.data: /var/lib/logstash
    #
    # ------------ Pipeline Settings --------------
    #
    # The ID of the pipeline.
    #
    # pipeline.id: main
    #
    # Set the number of workers that will, in parallel, execute the filters+outputs
    # stage of the pipeline.
    #
    # This defaults to the number of the host's CPU cores.
    #
    # pipeline.workers: 2
    #
    # How many events to retrieve from inputs before sending to filters+workers
    #
    # pipeline.batch.size: 125
    #
    # How long to wait in milliseconds while polling for the next event
    # before dispatching an undersized batch to filters+outputs
    #
    # pipeline.batch.delay: 50
    #
    # Force Logstash to exit during shutdown even if there are still inflight
    # events in memory. By default, logstash will refuse to quit until all
    # received events have been pushed to the outputs.
    #
    # WARNING: enabling this can lead to data loss during shutdown
    #
    # pipeline.unsafe_shutdown: false
    #
    # ------------ Pipeline Configuration Settings --------------
    #
    # Where to fetch the pipeline configuration for the main pipeline
    #
    # path.config:
    #
    # Pipeline configuration string for the main pipeline
    #
    # config.string:
    #
    # At startup, test if the configuration is valid and exit (dry run)
    #
    # config.test_and_exit: false
    #
    # Periodically check if the configuration has changed and reload the pipeline
    # This can also be triggered manually through the SIGHUP signal
    #
    # config.reload.automatic: false
    #
    # How often to check if the pipeline configuration has changed (in seconds)
    #
    # config.reload.interval: 3s
    #
    # Show fully compiled configuration as debug log message
    # NOTE: --log.level must be 'debug'
    #
    # config.debug: false
    #
    # When enabled, process escaped characters such as \n and \" in strings in the
    # pipeline configuration files.
    #
    # config.support_escapes: false
    #
    # ------------ Module Settings ---------------
    # Define modules here.  Modules definitions must be defined as an array.
    # The simple way to see this is to prepend each `name` with a `-`, and keep
    # all associated variables under the `name` they are associated with, and
    # above the next, like this:
    #
    # modules:
    #   - name: MODULE_NAME
    #     var.PLUGINTYPE1.PLUGINNAME1.KEY1: VALUE
    #     var.PLUGINTYPE1.PLUGINNAME1.KEY2: VALUE
    #     var.PLUGINTYPE2.PLUGINNAME1.KEY1: VALUE
    #     var.PLUGINTYPE3.PLUGINNAME3.KEY1: VALUE
    #
    # Module variable names must be in the format of
    #
    # var.PLUGIN_TYPE.PLUGIN_NAME.KEY
    #
    # modules:
    #
    # ------------ Cloud Settings ---------------
    # Define Elastic Cloud settings here.
    # Format of cloud.id is a base64 value e.g. dXMtZWFzdC0xLmF3cy5mb3VuZC5pbyRub3RhcmVhbCRpZGVudGlmaWVy
    # and it may have an label prefix e.g. staging:dXMtZ...
    # This will overwrite 'var.elasticsearch.hosts' and 'var.kibana.host'
    # cloud.id: <identifier>
    #
    # Format of cloud.auth is: <user>:<pass>
    # This is optional
    # If supplied this will overwrite 'var.elasticsearch.username' and 'var.elasticsearch.password'
    # If supplied this will overwrite 'var.kibana.username' and 'var.kibana.password'
    # cloud.auth: elastic:<password>
    #
    # ------------ Queuing Settings --------------
    #
    # Internal queuing model, "memory" for legacy in-memory based queuing and
    # "persisted" for disk-based acked queueing. Defaults is memory
    #
    # queue.type: memory
    #
    # If using queue.type: persisted, the directory path where the data files will be stored.
    # Default is path.data/queue
    #
    # path.queue:
    #
    # If using queue.type: persisted, the page data files size. The queue data consists of
    # append-only data files separated into pages. Default is 64mb
    #
    # queue.page_capacity: 64mb
    #
    # If using queue.type: persisted, the maximum number of unread events in the queue.
    # Default is 0 (unlimited)
    #
    # queue.max_events: 0
    #
    # If using queue.type: persisted, the total capacity of the queue in number of bytes.
    # If you would like more unacked events to be buffered in Logstash, you can increase the
    # capacity using this setting. Please make sure your disk drive has capacity greater than
    # the size specified here. If both max_bytes and max_events are specified, Logstash will pick
    # whichever criteria is reached first
    # Default is 1024mb or 1gb
    #
    # queue.max_bytes: 1024mb
    #
    # If using queue.type: persisted, the maximum number of acked events before forcing a checkpoint
    # Default is 1024, 0 for unlimited
    #
    # queue.checkpoint.acks: 1024
    #
    # If using queue.type: persisted, the maximum number of written events before forcing a checkpoint
    # Default is 1024, 0 for unlimited
    #
    # queue.checkpoint.writes: 1024
    #
    # If using queue.type: persisted, the interval in milliseconds when a checkpoint is forced on the head page
    # Default is 1000, 0 for no periodic checkpoint.
    #
    # queue.checkpoint.interval: 1000
    #
    # ------------ Dead-Letter Queue Settings --------------
    # Flag to turn on dead-letter queue.
    #
    # dead_letter_queue.enable: false
    
    # If using dead_letter_queue.enable: true, the maximum size of each dead letter queue. Entries
    # will be dropped if they would increase the size of the dead letter queue beyond this setting.
    # Default is 1024mb
    # dead_letter_queue.max_bytes: 1024mb
    
    # If using dead_letter_queue.enable: true, the directory path where the data files will be stored.
    # Default is path.data/dead_letter_queue
    #
    # path.dead_letter_queue:
    #
    # ------------ Metrics Settings --------------
    #
    # Bind address for the metrics REST endpoint
    #
    # http.host: "127.0.0.1"
    #
    # Bind port for the metrics REST endpoint, this option also accept a range
    # (9600-9700) and logstash will pick up the first available ports.
    #
    # http.port: 9600-9700
    #
    # ------------ Debugging Settings --------------
    #
    # Options for log.level:
    #   * fatal
    #   * error
    #   * warn
    #   * info (default)
    #   * debug
    #   * trace
    #
    # log.level: info
    path.logs: /var/log/logstash
    #
    # ------------ Other Settings --------------
    #
    # Where to find custom plugins
    # path.plugins: []
    #
    # ------------ X-Pack Settings (not applicable for OSS build)--------------
    #
    # X-Pack Monitoring
    # https://www.elastic.co/guide/en/logstash/current/monitoring-logstash.html
    #xpack.monitoring.enabled: false
    #xpack.monitoring.elasticsearch.username: logstash_system
    #xpack.monitoring.elasticsearch.password: password
    #xpack.monitoring.elasticsearch.hosts: ["https://es1:9200", "https://es2:9200"]
    #xpack.monitoring.elasticsearch.ssl.certificate_authority: [ "/path/to/ca.crt" ]
    #xpack.monitoring.elasticsearch.ssl.truststore.path: path/to/file
    #xpack.monitoring.elasticsearch.ssl.truststore.password: password
    #xpack.monitoring.elasticsearch.ssl.keystore.path: /path/to/file
    #xpack.monitoring.elasticsearch.ssl.keystore.password: password
    #xpack.monitoring.elasticsearch.ssl.verification_mode: certificate
    #xpack.monitoring.elasticsearch.sniffing: false
    #xpack.monitoring.collection.interval: 10s
    #xpack.monitoring.collection.pipeline.details.enabled: true
    #
    # X-Pack Management
    # https://www.elastic.co/guide/en/logstash/current/logstash-centralized-pipeline-management.html
    #xpack.management.enabled: false
    #xpack.management.pipeline.id: ["main", "apache_logs"]
    #xpack.management.elasticsearch.username: logstash_admin_user
    #xpack.management.elasticsearch.password: password
    #xpack.management.elasticsearch.hosts: ["https://es1:9200", "https://es2:9200"]
    #xpack.management.elasticsearch.ssl.certificate_authority: [ "/path/to/ca.crt" ]
    #xpack.management.elasticsearch.ssl.truststore.path: /path/to/file
    #xpack.management.elasticsearch.ssl.truststore.password: password
    #xpack.management.elasticsearch.ssl.keystore.path: /path/to/file
    #xpack.management.elasticsearch.ssl.keystore.password: password
    #xpack.management.elasticsearch.ssl.verification_mode: certificate
    #xpack.management.elasticsearch.sniffing: false
    #xpack.management.logstash.poll_interval: 5s


    он дефолтный
  • Почему traceroute показывает один хоп?

    djalin
    @djalin Автор вопроса
    сейчас уже другой провайдер, по оптике и проблема осталась- специально проверил. может от роутера еще - буду смотреть. оно как бы не мешает но...
    TTL - 1500
  • Mikrotik - где почитать про начальную настройку без проводов?

    djalin
    @djalin Автор вопроса
    а можно ссылку? - по названию не нашол.

    Быстрый старт там довольно неплох, и если подключать по кабелю - работает изкоробки.

    У меня даже трафик идет, но что-то не так .. пока не могу понять что5e41a19fb78ad483975098.jpeg
  • Mikrotik - где почитать про начальную настройку без проводов?

    djalin
    @djalin Автор вопроса
    конфиг

    # jan/02/1970 00:36:31 by RouterOS 6.46.3
    # software id = ****
    #
    # model = RB931-2nD
    # serial number = ***
    /interface bridge
    add admin-mac=*** auto-mac=no comment=defconf name=bridge
    /interface wireless
    set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-XX \
        disabled=no distance=indoors frequency=auto installation=indoor ssid=\
        netis wireless-protocol=802.11
    add disabled=no keepalive-frames=disabled mac-address= \
        master-interface=wlan1 multicast-buffering=disabled name=wlan2 ssid=m2 \
        wds-cost-range=0 wds-default-cost=0 wps-mode=disabled
    /interface list
    add comment=defconf name=WAN
    add comment=defconf name=LAN
    /interface wireless security-profiles
    set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk group-ciphers=\
        tkip,aes-ccm mode=dynamic-keys supplicant-identity=MikroTik \
        unicast-ciphers=tkip,aes-ccm wpa-pre-shared-key=password \
        wpa2-pre-shared-key=password
    /ip pool
    add name=default-dhcp ranges=192.168.88.10-192.168.88.254
    /ip dhcp-server
    add address-pool=default-dhcp disabled=no interface=bridge name=defconf
    /interface bridge port
    add bridge=bridge comment=defconf interface=ether2
    add bridge=bridge comment=defconf interface=ether3
    add bridge=bridge comment=defconf interface=pwr-line1
    add bridge=bridge comment=defconf interface=wlan1
    /ip neighbor discovery-settings
    set discover-interface-list=LAN
    /interface list member
    add comment=defconf interface=bridge list=LAN
    add comment=defconf interface=ether1 list=WAN
    /ip address
    add address=192.168.88.1/24 comment=defconf interface=bridge network=\
        192.168.88.0
    /ip dhcp-client
    add comment=defconf disabled=no interface=ether1
    /ip dhcp-server network
    add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
    /ip dns
    set allow-remote-requests=yes
    /ip dns static
    add address=192.168.88.1 comment=defconf name=router.lan
    /ip firewall filter
    add action=accept chain=input comment=\
        "defconf: accept established,related,untracked" connection-state=\
        established,related,untracked
    add action=drop chain=input comment="defconf: drop invalid" connection-state=\
        invalid
    add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
    add action=accept chain=input comment=\
        "defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
    add action=drop chain=input comment="defconf: drop all not coming from LAN" \
        in-interface-list=!LAN
    add action=accept chain=forward comment="defconf: accept in ipsec policy" \
        ipsec-policy=in,ipsec
    add action=accept chain=forward comment="defconf: accept out ipsec policy" \
        ipsec-policy=out,ipsec
    add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
        connection-state=established,related
    add action=accept chain=forward comment=\
        "defconf: accept established,related, untracked" connection-state=\
        established,related,untracked
    add action=drop chain=forward comment="defconf: drop invalid" \
        connection-state=invalid
    add action=drop chain=forward comment=\
        "defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
        connection-state=new in-interface-list=WAN
    /ip firewall nat
    add action=masquerade chain=srcnat comment="defconf: masquerade" \
        ipsec-policy=out,none out-interface-list=WAN
    /tool mac-server
    set allowed-interface-list=LAN
    /tool mac-server mac-winbox
    set allowed-interface-list=LAN

  • Mikrotik - где почитать про начальную настройку без проводов?

    djalin
    @djalin Автор вопроса
    Владимир Коротенко, что-то делаю не так, к точке подключился, с ми кротика тоже раздает - только подключиться не могу. 5e3ffaddbd89e079280977.png
    5e3ffaecba989723937567.png

    По кабелю с WI-FI тоже не пошло, хотя наоборот вчера получилось.

    Единственное я обновлял микротик - а именно пакеты system-6.46.3-smips и wireless-6.46.3-smips - может что еще доставлять нужно... В любом случае спасибо
  • Mikrotik - где почитать про начальную настройку без проводов?

    djalin
    @djalin Автор вопроса
    Рисовать для меня тяжело - попробую описать как должно быть в моем понимании.

    1. Есть 3G роутер, он раздает интернет по WI-FI (SSID=3G ).
    2. Микротик принимает его, обрабатывает и раздает дальше тоже WI-FI но уже с другим именем/паролем/SSID/ІР диапазоном (SSID=MikroTik ).

    Можно ли так сделать, и если можно как?
  • Как убрать знаки вопроса в ромбиках в WordPress?

    djalin
    @djalin Автор вопроса
    Да помогло, спасибо
  • Как убрать знаки вопроса в ромбиках в WordPress?

    djalin
    @djalin Автор вопроса
    Анатолий Куликов, Нет такого (excerpt_more) в functions

    нашол такое

    function get_home_blog_excerpt()
      {
        global $post;
        $excerpt = get_the_content();
        $excerpt = strip_tags(preg_replace(" (\[.*?\])",'',$excerpt));
        $excerpt = strip_shortcodes($excerpt);		
        $original_len = strlen($excerpt);
        $excerpt = substr($excerpt, 0, 145);		
        $len=strlen($excerpt);	 
        if($original_len>275) {
        $excerpt = $excerpt;
        return $excerpt . '<div class="blog-btn-area-sm"><a href="' . get_permalink() . '" class="blog-btn-sm">'.__("Read More","appointment").'</a></div>';
        }
        else
        { return $excerpt; }
      }


    Но что дальше - не знаю программирование - пока не мое
  • Как убрать знаки вопроса в ромбиках в WordPress?

    djalin
    @djalin Автор вопроса
    Вроде она

    function get_home_blog_excerpt()
    	{
    		global $post;
    		$excerpt = get_the_content();
    		$excerpt = strip_tags(preg_replace(" (\[.*?\])",'',$excerpt));
    		$excerpt = strip_shortcodes($excerpt);		
    		$original_len = strlen($excerpt);
    		$excerpt = substr($excerpt, 0, 145);		
    		$len=strlen($excerpt);	 
    		if($original_len>275) {
    		$excerpt = $excerpt;
    		return $excerpt . '<div class="blog-btn-area-sm"><a href="' . get_permalink() . '" class="blog-btn-sm">'.__("Read More","appointment").'</a></div>';
    		}
    		else
    		{ return $excerpt; }
    	}


    но я в программирование не очень - что конкретно заменить?
  • Как убрать знаки вопроса в ромбиках в WordPress?

    djalin
    @djalin Автор вопроса
    Анатолий Куликов, даже sans-serif так - буду искать еще
  • Как убрать знаки вопроса в ромбиках в WordPress?

    djalin
    @djalin Автор вопроса
    Шрифт Open Sans - какой посоветуєте попробовать?