Контакты

Достижения

Все достижения (2)

Наибольший вклад в теги

Все теги (4)

Лучшие ответы пользователя

Все ответы (5)
  • Перенаправление трафика в MikroTik

    chelaxe
    @chelaxe Автор вопроса
    инженер-программист
    В результате поступил так:
    1) Добавил ip адрес в список registry на котором находится сайт routerpwn.com
    /ip firewall address-list add address=74.208.139.97 list=registry
    2) Если пакет для ip адреса из этого списка то перенаправляю на порт 8080 в Web proxy
    /ip firewall nat add action=redirect chain=dstnat comment=registry dst-address-list=registry dst-port=80 protocol=tcp src-address=172.16.66.0/24 to-ports=8080
    3) Включаю прокси на порту 8080
    /ip proxy set enabled=yes
    4) Перенаправляю если обращение идет к routerpwn.com/info.html на 172.16.66.200
    /ip proxy access add action=deny dst-host=routerpwn.com path=/info.html redirect-to=«172.16.66.200\?host=routerpwn.com&get=info.html»

    Минус: не передается имя хоста и get запрос. По этой причине передаю их в параметрах get для 172.16.66.200 (172.16.66.200?host=routerpwn.com&get=info.html)
    Ответ написан

Лучшие вопросы пользователя

Все вопросы (5)